Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Rename blog to "news" in the URL

edited June 2011 in Modules
I'm on the Blog module settings screen (/fuel/blog/settings) and tried to change the path to the blog posts page that is by default at /blog to /news, but it doesn't appear to be working correctly. Go here to see the error:

http://dev.thehubway.com/news

If you go to http://dev.thehubway.com/blog you see the heading has changed to "News" but the news in the URL isn't working. Do I have to make a news.php controller for this to work? If so, what code do I put in there to redirect to the blog module?

Erik

Comments

  • edited 2:40PM
    Try adding these routes in your main config routes file:
    $route['news'] = 'blog'; $route['news/(:any)'] = 'blog/$1';
  • edited 2:40PM
    Excellent, thank you! This is basic CI stuff, so I shoulda realized this on my own, but thanks!
  • edited 2:40PM
    I have my blog area routed from /news perfectly, except no links within the blog module are working. If I click any title of a post, or do a search or click archives or authors, I get the 404 screen every time. What do you think is happening?
  • edited 2:40PM
    Try to click the titles of the blog posts here: http://dev.thehubway.com/news
  • edited 2:40PM
    I even uncommented the route declaration in config.php for the /news url routes and it is still the same behavior.
  • edited 2:40PM
    It looks like there is an ending slash missing on the URL after blog. Add that in the blog settings module under "URI".
  • edited 2:40PM
    THANK YOU! Fixed it!
Sign In or Register to comment.