Add Edit

I got this:

$fields['values'] = array(
'label' => 'Valores',
'type' => 'array',
'class' => 'add_edit',
'options' => $this->Product_feature_values_model->options_list(),
'value' => array_keys($this->Product_features_to_values_model->find_all_array_assoc('product_feature_value_id', array('product_feature_id' => $values['id']))),
'mode' => 'multi'

Everything is fine, except that when I hit the 'Add' button (next to the combo), the popup appears empty.
Any toughts?


  • edited 2:26PM
    Try adding the name of the module after add_edit.
    'type' => 'add_edit product_features',
  • edited 2:26PM
    I did this
    'class' => 'add_edit Product_feature_values_model',
    but it doesnt work. Also tried removing the "_model" but neither.
  • edited 2:26PM
    It should be the key value used in your MY_fuel_modules (not the model name). If that still doesn't work, does Firebug give you any insight as to what the error is? It should be Ajaxing in the content.
  • edited 2:26PM
    But I dont have that model set in MY_fuel_modules, neither I want it to be there. Is it mandatory?
    Also, I dont want the model visible on the sidebar.
  • edited 2:26PM
    It does need to be added so that the ajax request will work.

    You can manually set what appears in the left menu by configuring the fuel nav property $config['nav']['modules'] in fuel/application/config/MY_fuel.php (you'll need to add it). The default value is 'AUTO' which will automatically generate the list based on what is in your MY_fuel_modules file.
  • edited 2:26PM
    Ok got it!
    Is it possible to omit just one module using $config['nav']['modules']?
  • edited 2:26PM
    Not at this time... it's either a manual setup or an AUTO setup where it includes everything. At one point, there was a 'hidden' value you could assign but since I never used it, I removed it. However, I could see that being beneficial here. I'll put it on the list of things to look at.
  • edited 2:26PM
    Thanks bro
  • edited 2:26PM
    I've made a push recently so you can now add a "hidden" parameter to your module configuration that will hide it from the left hand menu:
Sign In or Register to comment.