Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

1.4_dev and CI3 class names

edited February 2016 in Bug Reports
I have been testing the 1.4_dev branche locally, without any problems. Then I tested the same application on a live server which resulted in a 404 error for each page I tried. Now the CI3 documentation says all class files should be capitalized, so this should go for controllers and models. I changed that in my advanced module and that solved the problem. I tried the same approach on the fuel controllers and models to see if it worked, but that seems to break the module and returns a blank page. Is this a known issue?

Comments

  • edited 4:07PM
    I've been developing mostly on a Mac and that hasn't cropped up yet so I appreciate the report. I've pushed a bunch of file casing updates. Please merge in the latest from 1.4_dev branch and test out when you can and let me know if you run across anymore issues.
  • edited 4:07PM
    Thanks. Most is working now. I have ran into the following issues:

    Pages > Create
    Pages > Edit

    Message: Undefined index: location
    Filename: models/Fuel_pages_model.php
    Line Number: 72

    I changed the casing of the model name. It helps for Edit, but Create still shows the location error. And I am missing all fields as defined in MY_fuel_layouts as well.

    Navigation > Create

    Content area seems to pop out, all navigation is lost.

    Assets/upload

    Throws this error:

    Message: Undefined property: Module::$linked_fields
    Filename: core/Model.php
    Line Number: 77

    Manage > Cache

    Throws a 404.

    I can give you access to the application, should you want to take a look yourself. Just let me know.
  • edited 4:07PM
    There was an issue in the routes file which I pushed a change to which should help:
    https://github.com/daylightstudio/FUEL-CMS/commit/b56f2cec810784fb30def7c6a7b2e2a20638cfa5
  • edited 4:07PM
    Thanks. The issues above related to pages and assets are solved now.
Sign In or Register to comment.