Created Page Not Showing Up in CMS

I created a new page for one of my FUEL projects, but it's not showing up on the "PAGES" page in the CMS. However, it's listed under the "Recently Modified Pages" on the dashboard.

Luckily the page is showing up on the website, but it's hard to get to if I want to edit, or unpublish.

Comments

  • edited 6:06AM
    Do you see an entry for that page in the fuel_pages database table?
  • edited August 2016
    Yeah it's in the db table.

    And I can even navigate to the page on the website. It's just not showing up in the list of pages within the CMS.
  • edited 6:06AM
    The page shows up in the "Select Another Page" dropdown in the top nav. Just not listed on the page itself. So weird.
  • does the page have any "special" characters in the location or title fields?
  • edited 6:06AM
    In the list view, if you look at the javascript console, it should be AJAXing in the table view that would include that page. What do you see there?
  • edited 6:06AM
    No special characters in the field.

    In the top right where is says show 50, I selected show 100, and the page listed. Maybe I accidentally deleted a 0 because I only have 6 total pages within the main module?
  • edited 6:06AM
    If you change it back to 50, does the problem come back (is it reproducible)?
  • edited 6:06AM
    I'm back working on the site now, I can't seem to find where the Show 50, is in the code. Been searching but I'm pulling my hair out. :)
  • edited 6:06AM
    The Show 50 displayed in the upper right is controlled by the modules "limit_options" parameter which by default is the follow for all modules but can be changed:
    // ... 'limit_options' => array('50' => '50', '100' => '100', '200' => '200'),
  • edited August 2016
    Thank you, I checked that, and the limit_options are correct. Nothing happened to that.

    SAFARI:
    Initially the page "video-tour" didn't list within the first 50 pages, so I renamed the page to "virtual-tour", and the page listed.

    I created another page to see if it was a naming issue and named it, "video-tour" and it's not showing up in the first 50 pages list. When I select show 100, it shows up.

    I cleared the cache (both fuel and browser cache), restarted browser and it still didn't update the page list.

    Safari still doesn't show correct page list after updating using Chrome.

    CHROME:
    Repeated steps like Safari, did the same thing at first, but the correct list showed when I cleared the cache. It listed the correct pages and within the limits.

    I created a "test" page and it listed after I cleared the cache, but in Safari it still does not show the new page. However, it showed up on the Dashboard under "Recently Modified..."

    DATABASE:
    The pages update in the database when I use either browser.
  • edited 6:06AM
    Some follow up questions:
    1. How many pages do you have on the site?
    2. Are there multiple lists of pages (pagination links) displayed and does it display on one of those?
    3. Are there any plugins installed on your browser that may be causing this difference.
    4. Is it something with the word "video"?
  • edited August 2016
    1. There are 5 pages total.
    2. I have 5 modules installed: Contact module, the blog model and three custom modules. None of it paginating yet. None of the links show up in the "pages" list, just the pages I have created that don't belong to a module.
    3. No plugins installed. However with Safari, I have issues viewing the live site and editing when logged in. The top right div for administration seems to push the divs on the live site down.
    4. I thought it was with the word video, but it seems to be a cache issue.
Sign In or Register to comment.