403 Forbidden after of delete the unique page called home in pages

I have installed well fuelcms, but while I was touching and trying to learn the system I broke the admin panel (i obtain the error 403 when try to acceso to [mypathbase]/fuel. I have only deleted one page in the pages section, I had got only one page called "home". What can i do to solve this issue?

Thank you very much.

Comments

  • edited 12:04AM
    Is your .htaccess setup to route things through the index.php? Does this URL work
    [mypathbase]/index.php/fuel?
  • edited January 2013
    My .htaccess on base of fuelcms has this aspect:

    ----------------------------
    Options +FollowSymLinks

    RewriteEngine On
    #RewriteBase /


    Order Deny,Allow
    Deny From All


    # Allow asset folders through
    RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

    # Protect application and system files from being viewed
    RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+|\.git.+) - [F,L]


    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule .* index.php/$0 [L]

    Options -Indexes
    --------------------------------------------------------

    I have to comment "RewriteBase /", because i have got this fuelcms in a subpath in my hosting (shared) (not yet I have got a domain), so the basepath is "[IP_OF_HOSTING]/myuser/fueldcmstest".

    It was working well but when I do the follow the admin zone gets me the 403.

    Create a new page with home name (special case if i rode well).
    Modify the page.
    Delete the page.

    Now, only works the front-end.
  • edited 12:04AM
    Ok. Here is the log trace from fuel_logs table:

    Pages item home edited
    Pages item home edited
    Pages item home edited
    Multiple module pages data deleted
  • edited 12:04AM
    I'm not quite sure I understand the last part where you say it "only works the front-end". If the page is deleted, in the CMS, then it will default to the home.php view file if it exists and if the "fuel_mode" in the fuel/application/config/MY_fuel.php is set to "auto".
  • edited January 2013
    Yes, when i put the home page, it works good. But when i try to go to [myip_and_subfolder]/fuel/or [myip_and_subfolder]/fuel/dashboard, it return me a 403 error in the browser.

    Otherwise, if i go to "[myip_and_subfolder]/fuel/pages/2", the login page is showed and i can go to the admin zone (backend).

    But, again, in this point if i click on dashboard, again it returns a 403 error.

    I do not know what is going on

    Is there a error log where see the error?
  • edited January 2013
    Hey admin, I forgot to remark important issue.

    My domain of the fuel cms test web page is something like this:

    http://184.154.x.x/~foouser/foo-fuel/

    In default home page i can see the link to admin page with this form:

    http://184.154.x.x/foo-fuel/

    I have been seing $config['base_url'] in config.php but i do not know what to change here to adapt the cms to my temporal domain.

    where can i set that my web path is "http://184.154.x.x/~foouser/foo-fuel/"
  • edited 12:04AM
    So it sounds like is FUEL installed in a "foo-fuel" subfolder? If so, these should be the links to your home page:
    http://184.154.x.x/foo-fuel/ (HOME)
    http://184.154.x.x/foo-fuel/home (ALSO HOME)
    http://184.154.x.x/foo-fuel/index.php (ALSO HOME)

    These should be the links to FUEL
    http://184.154.x.x/foo-fuel/fuel (SHOULD REDIRECT TO IF NOT LOGGED IN...)
    http://184.154.x.x/foo-fuel/fuel/login
  • edited 12:04AM
    I have reinstalled the files of fuel cms.

    Thank you again but i know that, although there is two subfolder (foo-user and foo-fuel), the first is of my user in my shared hosting.

    The problem is that the cms does not generate the those correct links.

    For example;

    - http://184.154.x.x/~foouser/foo-fuel/
    - http://184.154.x.x/~foouser/foo-fuel/index.php
    works well, it show me the default page.

    - http://184.154.x.x/~foouser/foo-fuel/home
    Does not work, it show me 404

    - http://184.154.x.x/~foouser/foo-fuel/fuel
    Does not work, it show me 404.

    I think that fuelcms is only prepare now to work with simple domains, that or I do not know where can i set my web path or root path or something

    Thank you very much by attention
  • edited 12:04AM
    It sounds like you don't have mod_rewrite enabled on your server. Does this work?
    http://184.154.x.x/~foouser/foo-fuel/index.php/home
  • edited 12:04AM
    Yes, that works.

    But I have some sites in my hosting and all uses mod_rewrite feature.
  • edited 12:04AM
    Ok, it works adding this $config['index_page'] = "index.php"; as fuel says in the home.

    but the form of the url are like this:

    index.php/fuel/pages

    index.php/fuel/dashboard

    index.php/home
  • edited 12:04AM
    That is usually an indication of mod_rewrite not working. Another possible thing to try is the following:
    http://ellislab.com/codeigniter/user-guide/installation/troubleshooting.html
Sign In or Register to comment.