Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

EDIT | VIEW | DELETE missing

I have created advanced module "training center" and simple module "profiles" inside the advanced one.
When I list the profiles in the CMS I can see the list, but rows are not clickable and there are missing EDIT | VIEW | DELETE buttons at the end of each row.
Is there any particular configuration to make it function as it should?
I have tried to find something on "blogs users" model and blogs configs but I cannot find anything relevant.
Please help!


  • Post your list_items() function...
    I'd check to make sure you have a primary key id for the table and that it's being included in your list?

  • Are you logged in as the super admin? If not, you may need permissions setup for your simple module:

  • edited April 2019

    I'm getting a little bit resigned about how things work.
    Yes, I'm logged as the super admin.

    The list_items() function is commented to be sure it works with default settings.
    After reading your post I have tried with this:
    public function list_items($limit = NULL, $offset = NULL, $col = 'birth_date', $order = 'asc', $just_count = FALSE)
    $this->db->select(', profiles.birth_date'); //uncomment and change to the fields to be displayed
    $data = parent::list_items($limit, $offset, $col, $order, $just_count);
    return $data;

    but nothing has changed.

    To go forward with my project I have abandoned above problem for a while and created new models (which will not be used as a webpages, but as a tables to edit in the CMS only) inside the advanced module with the command shell. I have configured the models, data in the config/{advanced_module_name}_fuel_modules.php, created even $config['tables'] inside config/{advanced_module_name}.php and after I click one of the new items in the CMS I see 404 page. Damn. Another problem... I have tested a lot of settings and simplified everything I could and nothing works out. I have even run the shell command to create simple module inside advanced module with same name as one of the models to create permissions in the database. At the end I have tried with creating controller files and nothing changed.

    I don't know how to move forward. Currently in my advanced module I have two simple modules without EDIT VIEW DELETE buttons and three models with 404 error in the CMS.

    I don't know, maybe I'm dumb....

  • Somehow EDIT | VIEW | DELETE buttons appeared.
    Don't know how and when.
    None the less, I still don't see the modules in the CMS.

  • I found why I didn't see the modules in the CMS.
    I had missing modules entries in config/{advanced_module_name}_routes.php

  • Glad you got it figured out.

Sign In or Register to comment.