Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Two same forms after submit

I have created a contact form in CMS with form module and after submission you can see the same form twice instead of once with after-submit text. I can't understand how it happens and what to do.

You can test it here -

Best, Lukasz


  • And one more thing:
    1. how to send a message also to the sender's email as a confirmation of sent email?
    2. how to put sender's email as the "from" field in the incoming email?

  • I ran a test on that form and I only saw the form rendered once upon submission as well as it only AJAX the results once so I'm not quite seeing the issue you explained.

    To send a response email, you would need to setup a custom function and leverage one of the form's hooks to send it out in the format you want using CI's Email class:

  • I just found the double form appears only with Firefox. Chrome process the website the right way.

  • edited March 31

    Ohh, please help. It is still there.
    The whole page is doubled under the contact form created in CMS - between reCaptcha and Submit button.
    The doubled page shows in tags:

    <tr>here is reCaptcha</tr>
        <td class="actions">
            <div class="actions_inner">
                <div class="messages success">
                    here is the doubled HTML of this contact page
                <input type="submit" name="Submit" value="Submit" class="submit" id="Submit">

    I've tried so many options, especially in the "Form" module's form

    The above html looks like this is a place for "After submit text", but a whole page is inserted.

    Please help.

  • Hmm... I not seeing that issue in Firefox after submission. Have you had other people test it out:

  • Finally I solved that by selecting "Javascript submit" to "no" in CMS in Forms config of the "Contact". After that I set that back to "yes" and this has started to work properly. Hell know what happened.

Sign In or Register to comment.