In line Edit button sometimes Not Showing

pscpsc
edited December 2010 in Bug Reports
After log in, I visit a page and expand the admin menu at the top. Sometimes the inline edit pencil doesn't show up.

If I click Back to Admin and Save the page (without changes) and then click View, *then* I can see the in line edit pencil.

chrome / osx.

Comments

  • edited 12:07AM
    The pencil icon should not show up when there are no editable fields. If the page is a static view file and has not been imported into the CMS as a page, then you may not see the pencil icon (only pages saved inside of FUEL are editable). The exception there is if you have a static view file in which you may have implemented fuel_edit() for perhaps a module element with the page. Does that explain what you are seeing?
  • pscpsc
    edited 12:07AM
    No that doesnt explian --

    The page has editable elements (the header and footer, plus, in these cases, the body). the page is already imported to the CMS. It may be that there is a static view file, but, either way, it has already been imported to the CMS on a previous session and I have used inline edit on the page in the past.

    The pencil icon to turn on inline editing in the admin tool bar doesnt appear until I go "back to admin" and then save the page (no changes made), and then click View again. Now the pencil shows up and I can inline edit. (that's a hack)

    If I log out, and log back in, same thing happens. No inline edit until I go and save the page from the admin interface again.


    After going back to admin, saving, and viewing, then inline edit becomes available once again.

    If you cant reproduce then perhaps this is a result of building from 0.90 and then updating all the files via FTP without any database changes when I upgraded to 0.91 ? ?
  • edited December 2010
    I'm able to replicate it locally... am looking into a fix and will keep you posted. It has to do with an issue cache with the cache. If you clear the cache it will appear (saving the page clears the cache which is why you see it after saving).
  • edited December 2010
    OK... I've pushed a fix so it will now ignore cached files if you are logged in and you should see those pencils every time now. The file updated is

    .9
    /fuel/modules/fuel/controllers/fuel_router.php
    https://github.com/daylightstudio/FUEL-CMS

    0.91
    /fuel/modules/fuel/controllers/page_router.php
    https://github.com/daylightstudio/FUEL-CMS/tree/0.91
Sign In or Register to comment.