Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Unable to locate the model you have specified: {model_name}

edited June 2017 in Bug Reports
Hi admin,

I have this fuel repo which I just deployed on a URL, everything works well on the local system. But as soon as I have pushed the repo on the remote url. I got 'Unable to locate the model you have specified: {model_name}' .
The file exists in fuel/application/models.

What could be the probable reason for it. Or the places that I should be looking out in order to debug this.

Here is the htaccess code:

Options +FollowSymLinks

RewriteEngine On
RewriteBase /cms/

Order Deny,Allow
Deny From All

# Allow asset folders through
RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

# Protect application and system files from being viewed
RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .* index.php?/$0 [L]

# Prevents access to dot files (.git, .htaccess) - security.
RewriteCond %{SCRIPT_FILENAME} -d
RewriteCond %{SCRIPT_FILENAME} -f
RewriteRule "(^|/)\." - [F]

Options -Indexes
The cms is pointed on
Usually you are very fast with responses. But just to signify the urgency, I have a demo lined up. :) Thanks.


  • edited 11:33PM
    Is mod_rewrite installed on the remote host?
  • edited 11:33PM
    However, I got the issue and was about to comment here for anyone else.
    I have been working on a windows machine which handles the filenames very well, small or captial it understands it well.

    But when shifted to linux - Filename becomes very important as Healthcare and healthcare are two different files.

    Upon search I cam accross this URL - which gave emphasis on filenames and hence I tried changing all my model filenames to start with Caps. Also the require_once command had

    Changed it to

    This worked!
    Still will like admin to checkout the documentation which says to create model without caps.
Sign In or Register to comment.