FUEL CMS 1.0 Beta on GitHub



  • edited 8:16AM
    When I try to manually install the user_guide from the command line (Windows), I get the 404 page.

    I'm using php index.php fuel/installer/install user_guide and am seeing the 404 html being returned.

    I tried replacing '/' with '\' but get a disallowed characters message
  • edited 8:16AM
    I'll look into that issue. In the meantime, you should still be able to see the user guide in the CMS. The installation for the user_guide just adds the appropriate permission which isn't really necessary for the user_guide unless you plan on assigning other folks that permission.
  • edited 8:16AM
    I just tried and was actually getting a slightly different error which I just pushed some fixes for regarding a file not existing. However, I ran the following command in the windows command line and it seemed to work OK. Do you have the"admin_enabled" parameter set in the fuel/application/config/MY_fuel.php set to TRUE?

    C:\xampp\php\php.exe C:\xampp\htdocs\v1.0\index.php fuel/installer/install user_guide
  • edited July 2012
    Of course! admin_enabled was FALSE, because I'd just rushed in a tried the command line immediately!! However, with "admin_enabled = TRUE" I now get an error about

    Unable to load the requested file: helpers/user_guide_helper

    I used the branch files available today. The only thing of note from my perspective is that I'm using port 83 (I have several other "root" projects running in WAMP locally).

    I used full path to the index.php:
    c:\wamp\ww1\index.php fuel/installer/install user_guide
    I also tried
    c:\wamp\ww1\index.php fuel/installer/install/user_guide
    as well as running the url
    but they all ended up with the same load error.
  • edited 8:16AM
    Did you see that error when installing or when trying to view the user guide?
  • edited 8:16AM
    I was able to replicate that error and pushed a fix for that helpers/user_guide_helper error mentioned earlier.
  • edited 8:16AM
    I can see the guide in the admin OK, I can't use the installer.

    UPDATE your recent fix has solved the issue!
  • edited 8:16AM
    Woo, it's very good to hear about updates of my favorite CI CMS! I've downloaded the beta and new features look really exciting! The graphical changes for the admin are also nice and user-friendly.

    The only error what I found is in User Guide module: the Localization page only load one and a half sentence without CSS (/fuel/tools/user_guide/general/localization).
  • edited July 2012
    I've pushed a fix for that.
  • edited 8:16AM
    Line 25 in MY_fuel.php contains an , that produces an error in the admin:

    $config['modules_allowed'] = array(
  • edited 8:16AM
    Are you sure that is what is causing the error? That shouldn't cause a parse error.
  • edited 8:16AM
    When I took it out the admin view was rendered ok... Strange. But than it's ok.
  • edited 8:16AM
    What is the error that you are seeing?
  • edited 8:16AM
    If I log in the fuel page is not loaded. I believe it was only the sidebar that was shown. I did not get an php error though. Just something with rendering the page went wrong. I just tried it again with the comma and everything is fine.... Just ignore my above posts.
  • edited 8:16AM
    So everything is OK now? Could it have perhaps been a cache issue if you upgraded an existing installation?
  • edited September 2012

    One question, must I rewrite some or all the files of my modules if I migrate from version 0.93 to 1.0? The only changelog from 0.93 to 1.0 that I found is here, but I don't know if there are big changes respect to modules development and modules compability with previous versions.

    I would appreciate some guidance or URL.

  • edited 8:16AM
    It depends a little on how things were coded, but chances are you may not need to change much if any. The biggest change is that advanced modules are automatically loaded on the the fuel object if you have a library with the same name as the module but prefixed with Fuel (e.g. Fuel_{module}). However, an advanced module does not require that you have that library.
  • edited 8:16AM
    How do I create Controller pages with 1.0, the following does seem to work,
    $page_init = array('location' => $view_name);
    $this->load->module_library(FUEL_FOLDER, 'fuel_page', $page_init);
  • edited 8:16AM
    Try using this in the controller instead (the documentation needed to be updated it looks like in the new User Guide gocs which I just pushed).
    // set your variables $vars = array('page_title' => 'Contact : My Website'); //... form code goes here $this->fuel->pages->render('about/contact', $vars);
  • edited 8:16AM
    after i add Authors Module following the user guide 1.0.
    1.create authors table
    2.add authors_model.php in fuel/application/model
    3.add $config['modules']['authors'] = array(); in MY_fuel_modules.php
    4.login admin

    But I can't see authors menu show on MODULE section.
    don't know why?
  • edited 8:16AM
    And you are logging in as the super admin user which has permission to everything I assume?
  • edited 8:16AM
    I've been using '$this->fuel->pages->render('about/contact', $vars);'. Works fine, expect the pages are fuelified. It is possible to render them un-fuelified ?
  • edited 8:16AM
    Try adding a variable of "fuelified" = FALSE; or defining a constant of "FUELIFY" to FALSE.
    $vars['fuelified'] = FALSE; $this->fuel->pages->render('about/contact', $vars); //...OR define('FUELIFY', FALSE); $this->fuel->pages->render('about/contact', $vars);
  • edited 8:16AM
    When is the release planned?
  • edited 8:16AM
    Unfortunately we don't have a timeframe. We have a few supporting things we are working on between client work so it's tough to give an estimate.
  • edited 8:16AM
    After i changed date_format in MY_config.php
    $config['date_format'] = 'Y/d/m';

    All works fine before i save it.
    After i saved it, the date becomes empty.

    is this caused by Validator?
  • edited 8:16AM
    It is probably due to 'Y/d/m' not being recognized as a valid date string by the strtotime function. Valid formats can be found here:
  • edited 8:16AM
    sorry, i have some type error on previous post.
    my setting is:
    $config['date_format'] = 'Y/m/d';

    'Y/m/d' is a valid format.
    But the date still be cleared after save.

    I also test the strtotime function.
    strtotime('11/18/2012') is the same as strtotime('2012/11/18').
  • edited 8:16AM

    Where did the modules backup, blog, cronjobs, seo, tester, user_guide and validate disappear from the './fuel/modules' directory?

    I mean, I am about to upgrade from 0.9.3 to 1.0 and while I was browsing/comparing the folders in both versions noted that the a/m modules from 0.9.3. are not present in 1.0.

    Do we get them from the 'Master' branch?
  • edited 8:16AM
    With 1.0, those are now separate modules which can be found at the link below. To install, you can download the zips and put them in the modules folder with the same names used in 0.9.3.
Sign In or Register to comment.