Crazy problem with input fields not converting quotes!

edited May 2012 in News & Announcements
I need help! I'm probably on an outdated version or something, but I just found out that in one of my first projects with fuel from (2011) anywhere there's an input field double-quotes (like "this") don't get escaped automatically and the field they're in gets truncated inside the Fuel forms...
take a look here http://imgur.com/a/YMK2F
as you can see the quotes are saved fine (see the title on top of the form), but they're not converted to html entities upon saving.. this only happens in this particular project and I can't seem to understand why... i'm sure i didnt hack anything out of the source!
Is it possible this was a bug solved in a later version? I've tried replacing the Form_builder class with a recent version but no changes at all... please help! thanks!

Comments

  • edited 3:01PM
    Very possible. I would first look at replacing the safe_htmlentities function in the MY_string_helper to the latest to see if that helps.
  • edited 3:01PM
    M;mmh that didn't help, the functions were identical... what else could it be?
  • edited 3:01PM
    Hmm... what about the Form::prep method?
  • edited 3:01PM
    nope, that didn't help... damn, what can it be?!
  • edited 3:01PM
    I'm not quite sure. A couple other files you may want to try replacing:

    fuel/application/core/MY_Model.php
    fuel/modules/fuel/controllers/module.php
  • edited 3:01PM
    ok i'll give those a look and report. thanks!
Sign In or Register to comment.