Need installation help

edited December 2010 in Installation
Still on the Getting started screen.
Database configured as in the instructions. DB created, user assigned, config file altered to reflect the changes.
Permissions assigned as instructed. (that part turned green)
I copied a .htaccess file from a WP installation, and it reads:


RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]


It's located in the root of the fuel folder.

So how do i get started?

Comments

  • edited 6:34AM
    If the FUEL installation is in a subfolder on your web server named FUEL then make sure your RewriteBase is the following in your .htaccess:
    RewriteBase /fuel/
    If mod_rewrite is working then you should be able to go to:
    http://mywebsite.com/fuel and login with uid: admin, pwd: admin

    In addition, you can go into the application directory and start adding your CodeIgniter specific project code, create static view files (if you don't want to use the CMS), controllers, models etc.
  • The website is located in /var/www/fuel
    It has its own domain name, fuel.foo.bar
    When i enter that in the browser i get the fuel Getting Started screen.
    Since it's not in a subfolder, i left the rewrite base to /.
    However, even if i modify the config file to say index.php, i still get the getting started screen.
  • Is there a specific location where the .htaccess file needs to be?
    Like i mentioned above, its located in the root folder of the fuel installation
  • edited 6:34AM
    The .htaccess is in the correct spot. Are you able to access the FUEL admin (should be link below install directions)?

    Here is another thread that relates to problems getting errors while trying to access the FUEL admin that may help:
    http://www.getfuelcms.com/forums/discussion/3/problems-with-.htaccess-and-404-
    dashboard-not-found/#Item_18
  • After i did the index.php? string, i can now enter the admin.
    But if i create a page, and try to access it, i get a 404?
  • edited 6:34AM
    You did the index.php? change to the .htaccess file correct? Did you change the $config['uri_protocol'] = 'QUERY_STRING'; ?
  • edited 6:34AM
    setting the $config['uri_protocol'] = 'QUERY_STRING'; messes up the admin page but when set to AUTO, I can't see the pages I create
  • edited 6:34AM
    Are you able to get a normal CodeIgniter 2 instance up and running OK on this server and able to browse to sub pages?
Sign In or Register to comment.