Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

An Error Was Encountered - The configuration file fuel.php does not exist.

edited December 2010 in Installation
Hi,
first of all best wishes for the project!

I've tried to install FUEL, but when i navigate to the root of my site will appear the message in object.

What i can do for solve this issue?

Thanks,
Moreno
Italy

Comments

  • edited 5:08AM
    A few questions?

    1. What platform are you using to run FUEL (MAC, Unix, Windows XAMPP, WAMP)?
    2. Did you create a subfolder on your web server to install FUEL or does it exist at your server's web root directory?
    3. What URL did you use to try and access the site?
  • edited 5:08AM
    Hi,
    i use easyphp on Windows.

    I've create a subfolder name fuel.dev
    than i have add a virtualhost (127:0:0:5 - www.fuel.dev) on my apache that point to www/fuel.dev.
    Than in my hosts file i have set the redirect to 127:0:0:5 for www.fuel.dev.

    I use always these settings, without problems.

    I have notice that if i rename the file /fuel/application/config/MY_fuel.php to fuel.php i see the custom 404 error page.

    Thank you
  • edited 5:08AM
    Couple more questions:
    1. What is the URI path that you are using to see that error (is it just the homepage?)
    2. Have you been able to get CodeIgniter projects to work on your server before (http://codeigniter.com)?
    3. Do you have .htaccess and mod_rewrite enabled for your Apache server
  • edited 5:08AM
    1- i've the same problem in www.fuel.dev and www.fuel.dev/fuel both.
    2- Yes, i usually use it without problem.
    3- Yes of course, i have mod_rewrite and .htaccess enabled

    :)
  • edited 5:08AM
    Are you using the 0.90 version or the 0.91 version on GitHub? The 0.91 version uses Modular Separation and CI 2.0. The error you are seeing could be happening around line 88 in the fuel/application/libraries/MY_Config.php file in version 0.90 which uses Matchbox to create it's module folders. I'd be curious if you have the same problem with version 0.91:
    https://github.com/daylightstudio/FUEL-CMS/tree/0.91

    I'm not sure why you'd be getting that error message at the moment but narrowing down which version may help.
  • edited 5:08AM
    With 0.91 version works!

    Thank you for your support :)
  • edited 5:08AM
    OK... good to know.
  • edited 5:08AM
    I made a change to the 0.9 version that may fix that issue. I basically explicitly state where to find the FUEL config file. I changed line 34 in the fuel/module/fuel/libraries/Fuel_base_controller.php to the following:
    $this->load->module_config(FUEL_FOLDER, 'fuel', TRUE);
    Not sure why it was an issue for you though.
Sign In or Register to comment.