Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Unable to see edit inline

edited November 2011 in Modules
Hi,

I've set up a fuel site previously and the inline edit worked fine.

But I'm setting up another, separate site, and although the toggle edit button appears across all pages during preview - and I can change templates, there are no editable areas (denoted by the pencil) appearing.
I've imported the page into the admin area, and can make changes through that - but the editable inline sections don't show.

I've got a main.php template file - and I'm trying to include the editable body section using

<?php echo fuel_var('body', ''); ?>

This shows the content from a separate home.php view.

I've been over the inline examples and faqs many times - was wondering if I've missed a simple "turn on inline editing" option somewhere.

Love the CMS!

Thanks
Matt

Comments

  • edited 2:20PM
    Does it work if you create another page (not imported)? Also, are there any javascript errors that you see?
  • edited 2:20PM
    Unfortunately not, creating another page makes no difference, and there aren't any javascript errors - but I have started to strip down all superfluous code (legacy from previous versions). But think it may be something in my frontend - will get back to you once I've got to bare bones and sorted out validation...
  • edited 2:20PM
    Ok,
    Page validates, and have stripped out old code, but edit sections are still not showing up.
    Just checked the generated html, and there are no "__fuel_marker__" spans being added to the sections that should be editable.
    The page has been uploaded to the cms.
    Should this automatically allow the section to be editable inline? Are there any other parameters that may need to be set?

    Cheers for your help...
  • edited 2:20PM
    ...aaargh!

    fixed it - was missing an tag at the top of the page...must have been stripped out at some point. Inline tags don't work without it - due to the if else switch in the render_all_markers function in Fuel_page.php.

    Hopefully this will help if someone else comes up with the same issue! :)
  • edited 2:20PM
    Glad you figured it out and posted back.
  • edited 2:20PM
    ...no probs. And just noticed that the forum has stripped out the html - should have been "missing an [html] tag at the top of the page"...
Sign In or Register to comment.