Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Blog module: Problem submitting comments

edited October 2011 in Installation
Comments must be submitted through the form on the website.

That's the error I get when I try to submit a comment using the standard form.
Also the captcha recognition fails systematically (I mean I tried 10 times, even considered that it might be case sensitive).

Any thoughts?
Thanks a lot!

Comments

  • edited 9:47PM
    Try making the fuel/modules/blog/assets/captcha folder writable.
  • edited 9:47PM
    I cleaned the captcha folder to check that file are being written correctly.
    It seems that every time the comment form is displayed 2 captchas are created, the first being displayed and the second one being the good one.
    However even when I enter the good one I still have the "Comments must be submitted through the form on the website" error.

    I tried to restore the default template but the problem is the same.
    I'm gonna try with a clean install from github and compare the files from the blog module..
  • edited 9:47PM
    This issue comes from a jquery plugin that, for some reason, sends a GET request to to page once it's loaded causing it to generate another captcha and (I guess) another antispam value.

    Sorry for the trouble.
  • edited 9:47PM
    No worries. Glad you figured it out and posted the solution back here for others.
Sign In or Register to comment.