Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

404 On All Pages

edited September 2011 in Installation
I've been able to install FuelCMS 0.93 on localhost using XAMPP on linux. Using the admin section is no problem. The problem is viewing a page I get 404 errors for every page I create.

This has happened with the demo branch as well as main. My directory structure is:
htdocs/fuelcms/

I access the dashboard at:
http://localhost/fuelcms/fuel/dashboard

The preview pages take me to:
http://localhost/fuelcms/about (404)
http://localhost/fuelcms/test (404)

Here is my htaccess file's contents:
Options +FollowSymLinks

RewriteEngine On
RewriteBase /fuelcms/


Order Deny,Allow
Deny From All


# Allow asset folders through
RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

# Protect application and system files from being viewed
RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+|\.git.+) - [F,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .* index.php/$0 [L]

Options -Indexes

I've tried changing to QUERY_STRING as instructed in the forums. The results were the same, dashboard works, viewing a page does not. I'm out of ideas, please help.

Comments

  • edited 9:03PM
    Have you set the fuel_mode to "auto" in the fuel/application/config/MY_fuel.php file?
Sign In or Register to comment.