206 Partial Download problem

edited July 2011 in Installation
I've just converted a site from Codeigniter to Fuel, and uploaded it to my host. A few teething problems, as expected! But one that has got me a bit stumped. One of the images I am using for the background isnt loading.

Using firebug, I've determined that the image download is failing on a 206 Partial Download. Apparently the server is doing nothing wrong - see here: http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html - a 206 is in response to a partial GET request!

I'm thinking there is a config in Fuel somewhere causing my site to send a partial request due to range limiting on image downloads? With the raw codeigniter site, I didn't have this problem. The image is only 513K.

Any words of advice, as I'm pulling my hair out here!

EDIT: Further info - Reponse header is sending this back:

"Content-Length 499250
Content-Range bytes 16384-515633/5156342"

And this is the content part of the GET request - The request header seems imcomplete in the range field:
"Range bytes=16384-"

Cheers.

Comments

  • edited 7:31AM
    When you say isn't loading, do you mean when you browse to the site that the background images doesn't appear? If so, I'm not sure what in FUEL would cause that issues since it just generates the HTML that has the CSS/images in it. Is the image in the assets/images folder?
  • edited 7:31AM
    I think it's all part of a bigger issue I'm having. I think I'm having some sort of routing issue.

    When accessing my page directly using the domain name, www.mysite.com, the css doesn't load. The css helper (echo css('style')) seems to append the name of the directory folder that I kept my development site in front of the css link. But then things get weird. If I log in using www.mysite.com/fuel, then view the site from admin, it renders correctly, and in viewing the page source, the css helper has given the correct url link for the css file.

    Will there be somewhere in config that I have not set the routes used by the css and js helpers properly? Does WEB_ROOT have anything to do with it? I've been through all the config files and can't seem to find anything.
  • edited 7:31AM
    Ah-ha! Think it's solved.

    I went into admin and resaved the home page - that seems to have solved it. I had added the page through admin on my development site. I thought I would just be able to drop everything in from my development box to the live. Guess not!

    So I guess admin sorts out the assets paths automatically? is this assigned through WEB_ROOT?
  • edited 7:31AM
    Yes... It's best to use the Asset helper to input paths to images, css, js, etc so those paths are more portable in situations like that. It uses WEB_PATH as well as some other information to determine the path to the assets.
  • edited 7:31AM
    Thanks :-)
Sign In or Register to comment.