Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

JQX Errors in Admin after upgrading to 1.4 from 1.2 (PHP 7.2)

edited November 17 in Installation

So I'm using the develop branch of 1.4 on PHP 7.2 -- Upgrading from 1.2 -- the front-end of the site displays pretty well...I've got some issues to work out with "FUEL_MARKER" showing up in some weird places...but I don't think that's a big deal.

My main issue at the moment is that in the admin area...content is not showing up (the counts show up -- https://prnt.sc/ljld1c -- , and that all seems correct)...but I'm getting several errors that are preventing JQX from returning the content to the screen (screenshot: https://prnt.sc/ljla07) -- the wheel just keeps spinning.

The errors are:

Uncaught SyntaxError: Unexpected token <
Uncaught SyntaxError: Unexpected token <

jqx.js?c=-62169955200:108 Uncaught TypeError: controllerObj is not a constructor
at Object.jqx.initCallback (jqx.js?c=-62169955200:108)
at readyCallback (jqx.js?c=-62169955200:77)
at jqx.js?c=-62169955200:92
at dispatch (jquery.js?c=-62169955200:3)
at i (jquery.js?c=-62169955200:3)

The first two seem to be because it's trying to dump the homepage to the screen...but I'm guessing those are due to the other error (the jqx error).

This seems to be the init on the dashboard page for example:

jqx.addPreload('fuel.controller.BaseFuelController');
jqx.init('fuel.controller.DashboardController', [], '/fuel/modules/fuel/assets/js/');

Been beating my head up against this for a few hours, so any help would be greatly appreciated!

Comments

  • Is this happening with a fresh installation?

  • edited November 18

    It’s a fresh install of 1.4, but I’ve copied all of my controllers and models and renamed them as instructed. The front-end of the site is displaying and working fine as far as I can tell...just running into this jqx issue with the backend.

  • Do those errors appear before you copied over all your stuff?

  • That’s a good question. To be completely honest, I didn’t check the admin before copying stuff over. I’ll give that a check tomorrow and report back.

  • Just an update, I think I've narrowed it down to something in my .htaccess file. After a fresh install of Fuel 4...everything was fine...started adding things back from my current site one step at a time, and on the very first step ran into the error when I copied my .htaccess file over. Will let you know what it is if it's something not super specific to my install. Cheers again for the suggestion...I have NO idea why I didn't think to do that (I think it was because everything was working on the front-end, so I just assumed...stupidly).

  • So this was basically being caused by a internal apache function (tolower) I was using on my previous server to force all urls to lowercase that wasn't working on this one...not sure if it's an apache config issue or something that the newer version of Fuel doesn't like (I'm sure it's the former and not the latter). So, long story short...it was specific to my install.

    That being said...I am running into some PHP 7.2 issues with countable here and there that are Fuel related (like the "Tree" view in the admin)...where would you like me to post those issues? Github, or in the forum?

  • GitHub please with replicating steps.

Sign In or Register to comment.