Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

How to initialize Markitup with Markdown?

I'm using this according to the docs: http://docs.getfuelcms.com//general/forms#wysiwyg

'type'         => 'wysiwyg',
'editor'       => 'markitup',
'markdown'     => TRUE,

But it doesn't render the Markdown editor. Just the standard HTML editor.

I can force it, if I set

            if($elem.data('markdown')){
                editorSet = 'markdown';
            }

in custom_fields.js, but... do I miss something? Or is it a bug?

Comments

  • That seems to be a bug / typo: You can initialize it by setting it with the editor_config parameter:
    'editor_config' => 'markdown'

  • editor_config does work. Thank you.

    Just for the record:

    'type'         => 'wysiwyg',
    'editor'       => 'markitup',
    'editor_config' => 'markdown',
    'markdown'     => TRUE,
    'ignore_representative' => TRUE
    
  • Thanks for fixing it in the latest dev release!

Sign In or Register to comment.