Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Object not found fuel/start

I am trying to install fuelcms but i reached this error. I already changed my .htaccess, config. When i clicked the admin part, this was the error

Object not found!
The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
Apache/2.4.33 (Win32) OpenSSL/1.1.0h PHP/7.2.5

Hope you can help me with this. Thank you.

Comments

  • Did you enable the admin in fuel/application/config/MY_fuel.php (by default it is set to FALSE)

  • $config['admin_enabled'] = TRUE;

    Yes I already changed it to TRUE

  • Do you have mod_rewrite enabled in your apache config?

  • LoadModule rewrite_module modules/mod_rewrite.so
    Yes its enabled. I was once installed it on my windows 7 desktop. But when i tried on my windows 10.. this was I encountered.

  • Does a page show up here:
    http://{myserver.com}/index.php/fuel/login

    Also, is your site in a subfolder on your server? If so, you may need to change your .htaccess

  • Hi I've just setup the system but it redirects me to xampp dashboard. any help?

  • I moved my production site to a dev environment in a directory
    Kinda the same issue I can only get the index page to work in the subdirectory where the site is on my test environment

    192.168.0.55/jack/
    The index page of the site comes up.

    If I do 192.168.0.55/jack/about

    The requested URL /jack/about was not found on this server.
    But it is a valid path on the production site.

    My mod rewrite in the root of the /jack/ directory

        <IfModule mod_rewrite.c>
            RewriteEngine On
            RewriteBase /jack
    
            #RewriteCond %{SERVER_PORT} 80
            #RewriteCond %{HTTP_HOST} ^192.168.0.55/jack
            #RewriteRule ^(.*)$ http://192.168.0.55/jack/$1 [R,L]
    
            <Files .*>
                Order Deny,Allow
                Deny From All
            </Files>
    
            # Allow asset folders through
            RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]
    
            # Protect application and system files from being viewed
            RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]
    
    
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
    
            RewriteRule .* jack/index.php/$0 [L]
    
            # Prevents access to dot files (.git, .htaccess) - security.
            RewriteCond %{SCRIPT_FILENAME} -d
            RewriteCond %{SCRIPT_FILENAME} -f
            RewriteRule "(^|/)\." - [F]
    
        </IfModule>
    

    I assume Im not configuring something correctly. Any ideas?

  • edited February 25

    Yes, I tried the other 2 settings PATH and the QUERY and changed it back to REQUEST and then changed the index.php (which was blank) to index.php? and none of it worked. I moved the site to the root just to make things simpler for now but still getting page not found.

    This is on a Raspberry Pi with Apache and MySQL. The Mysql is connected to the site. the .htaccess in the root of the html directory same as the index.php file

  • Does Apache have the mod_rewrite module installed and does it allow .htaccess for that directory? Does 192.168.0.55/index.php/jack/about work?

  • mod_rewrite is installed and on

    I moved the site the the root of html to simplify trouble shooting

    Now when I click about I get this is the URL and a Forbidden

    http://192.168.0.55/192.168.0.55/192.168.0.55/................./about

    with the IP (domain repeated numerous times)

    Obviously this is a server config problem and not Fuel. Ill continue to investigate but if anyone has suggestions I'm willing to hear.

  • Try removing "jack/" from this line:

    RewriteRule .* jack/index.php/$0 [L]
    

    You've already set it in the RewriteBase which should be changed to the following to include the ending "/":

    RewriteBase /jack/
    
  • I moved the site to the root of /html. There's no longer a /jack directory

  • And the .htaccess was updated to have the following correct?

    RewriteBase /
    ...
    RewriteRule .* index.php/$0 [L]
    
    // OR with the added ? per https://codeigniter.com/user_guide/installation/troubleshooting.html
    RewriteRule .* index.php?/$0 [L]
    
  • Options +FollowSymLinks
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
    
        #RewriteCond %{SERVER_PORT} 80
        #RewriteCond %{HTTP_HOST} ^192.168.0.55
        #RewriteRule ^(.*)$ http://192.168.0.55/$1 [R,L]
    
        <Files .*>
            Order Deny,Allow
            Deny From All
        </Files>
    
        # Allow asset folders through
        RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]
    
        # Protect application and system files from being viewed
        RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]
    
    
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
    
        RewriteRule .* index.php/$0 [L]
    
        # Prevents access to dot files (.git, .htaccess) - security.
        RewriteCond %{SCRIPT_FILENAME} -d
        RewriteCond %{SCRIPT_FILENAME} -f
        RewriteRule "(^|/)\." - [F]
    
    </IfModule>
    Options -Indexes
    
  • <Directory /var/www/html/>
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order deny,allow
        Allow from all
    </Directory>
    
  • I uploaded the site to a remote server under a domain I had and the site works well in Chrome, no problems. The site does error out in MS Edge. Index page works and looks great. If I click a link it errors out with a 414

    http://domain.com/index.php/index.php/index.php/index.php/index.php/index.php/index.php.........../about

    What would make the index.php repeat until it errors out?

  • FIXED!

    So long story and I doubt anyone ever runs into this.... BUT... I developed a brand new site on a production server some time ago. Time to update needed a dev. environment. Configured a Raspberry Pi to be my dev. Downloaded the site and put it all on the Pi. The circular reference was strangely due to not being HTTPS but I have HTTPS redirects in some of the files.
    Enabled SSL on the Pi (not easy but not hard) and it all works now.

Sign In or Register to comment.