Problems with .htaccess and 404 "Dashboard not found"

edited December 2010 in Installation
Two Problems following the Getting Started Instructions
1. Alter your Apache .htaccess file to the proper RewriteBase directory. The default is your web servers root directory. If you do not have mod_rewrite enabled you will need to change the $config['index_page'] from blank to 'index.php'
I cannot find where to change the $config['index_page'] from blank to 'index.php'. What document is this?

6. WARNING: Make sure the data_backup folder and crons folder is inaccessible to the web. The .htaccess file that comes with FUEL, blocks the fuel/data_backup and fuel/cron folders by default
I cannot find the .htaccess file that comes with FUEL. Where is it once the ZIP file has been unzipped?

Dashboard Not Found
When I tried to access the FUEL Admin (Step #7), I get a 404 error: The requested URL /FUEL-CMS/fuel/dashboard was not found on this server. There is no dashboard folder in the ZIP file, nor does one appear to have been created from the instructions I followed.


  • edited 4:06AM
    The .htaccess file should be at the folders root level. My guess is you need to turn on hidden files (which may be good to point out in the docs to prevent confusion).

    The $config['index_page'] parameter is in the fuel/application/config/config.php file

    I think if you get those things rectified, your 404 error will go away. There is no dashboard folder because it uses mod_rewrite to route everything through the index.php file. The actual path to the file is FUEL-CMS/index.php/fuel/dashboard. Let me know how it goes.
  • edited 4:06AM
    Hello guys,
    I've noticed people having problems installing the FUEL in a folder within a domain.

    If the installation was done within a folder in the field, then you should comment out the line in the file .htaccess

    #RewriteBase /

    Look at your log and check APACHE, for surely he could be trying to get the file "index.php" from the root folder of the domain and not the folder where the files FUELCMS.

    For example, I was using XAMPP on Windows.
    My web ROOT is:
    But the folder with the files were in FUEL:

    APACHE checked the logs and had the following feedback:

    [Thu Dec 02 00:08:07 2010] [error] [client] script 'D:/www/index.php' not found or unable to stat, referer:

    In my case it was sufficient to comment out the line:
    #RewriteBase /

    ---- (Excuse my English)

  • edited 4:06AM
    Jeff thanks for the tip on the #RewriteBase / fixed my issues.

  • edited 4:06AM
    Just got my version up and running. I had the issue with RewriteBase / as well, but I found that should be the path of where the fuel files are. So i use WAMP and I put my installation in a folder fuel_cms, so I changed the 'RewriteBase /' to 'RewriteBase /fuel_cms' and it worked just fine.

  • edited 4:06AM
    As an FYI, if you were using the 0.91 branch, there was a key file that was missing at fuel/index.php which was simply a header redirect to fuel/dashboard. That was fixed a couple days ago.
  • got a similar issue/question.

    on our test site ive got an instance of fuel cms going with just a few changes.. im having the same issue getting into the fuel admin area. ive commented out the rewrite on the root. ive also set $config['index_page'] = "index.php";

    i must be missing something simple :)

    great product btw.
  • edited 4:06AM
    Did you set $config['admin_enabled'] = TRUE; in the fuel/application/config/MY_fuel.php?
  • correct -> $config['admin_enabled'] = TRUE;
  • edited 4:06AM
    Are you able to access it at http://localhost/index.php/fuel (instead of just http://localhost/fuel ... and replacing localhost with your server name) ?
  • that does work. so its got to be an htaccess/mod rewrite issue??
  • edited 4:06AM
    Maybe it is htaccess. But before we go more down that route, try the following:

    1. Got to the fuel/application/config/config.php file and change
    $config['index_page'] = 'index.php?'; // Note the question mark at the end
    2. In the same config file, right below the index_page config item, change $config['uri_protocol'] = 'QUERY_STRING';

    Here is a link that may help as well regarding this similar issue:
  • still the same issue. without the index.php? it fails...
  • edited 4:06AM
    If you still have the .htaccess enabled, change the line towards the bottom where it says
    RewriteRule .* index.php/$0 [L]
    RewriteRule .* index.php?/$0 [L]

    If not, are you familiar with CodeIgniter ( and have you been able to get it successfully installed in the past using .htaccess?
  • that fixed it :) thank you for the time! looking forward to building this into our first site!
  • edited 4:06AM
    Glad to hear that worked. That particular issue has stumped me several times myself so hopefully you'll store that one away better then I did.
  • edited 4:06AM
    Thanks! The question mark in .htaccess solved it for me, too. I had been pulling my hair out for a while... :-)
  • edited 4:06AM
    As an FYI, you'll have the same problem with CodeIgniter projects (this isn't specific to FUEL). It has to do with the server. For example, your server may not having the $_SERVER['PATH_INFO'] environment variable set and that is why the $config['uri_protocol'] has those different options.
  • edited 4:06AM
    Hi, i followed the steps in the getting started but the problem I have is when I'm trying to login.

    When i push the login button it refresh the page but doesn't take me to anywhere but the login page again. How can i fix it?
  • edited 4:06AM
    Try clearing any CI session cookies from your browser.
  • edited 4:06AM
    I have the same probem. Since yesterday I had the .htaccess disabled and I was able to test the project, but now I move all the files to a testing machine with apache and mod_rewrite enablel, so I would like to use it.
    I put the application inside a subdir named 'admin' (because I'm using fuel to build the web site's cms, and not the front-end) and here I put .htaccess file with the following lines:

    RewriteBase /sitename/admin/

    so, my address would be

    but I get the 404 error.

    I tried with
    RewriteBase /sitename/ or RewriteBase /

    but it doesn't work.

    I tried to add the following line

    RewriteRule .* index.php?/$0 [L]

    and what I get is the right login page, but the relative path to css, js, images and other stuffs are obviously wrong, so I can't display the page correctly. I don't know how can I do to work with mod_rewrite correctly. Can you give me some advice ?

    By the way, I hope that with mod_rewrite enabled, the pagination will work, because now , working without mod_rewrite, I have more than 25 records, and if I go to the second page my url is


    but the application still shows the first 25 records
  • edited 4:06AM
    A couple questions?

    1. What is the path for the broken assets?
    2. What happens if you change the uri_protocol in the config to one of the other options?
    3. What kind of dev environment (MAMP, WAMP, etc)?

    The pagination issue looks like it was a regression bug that I've just posted a fix for:
  • edited 4:06AM
    1. for example:/sitename/admin/fuel/modules/fuel/assets/css/datepicker.css?c=943948800
    2 I get the same result, with or without the line RewriteRule .* index.php?/$0 [L]
    3 I'm using MAMP

    About the, it works like a charm :-) great!
  • edited 4:06AM
    That looks like the correct asset path to me. Line 12 and 15 in the .htaccess are used to block access to all folders in fuel except asset files. What happens if you comment those out for now to test?
  • edited 4:06AM

    Sorry, on my testing machine, I've realized that I was using the wrong .htaccess.
    With the right file all works as well in my localhost server.
    But when I pubblish the project to the web space provided by my ISP, keeping the original .htaccess, I get the 500 error.

    I've solved the problem, by commenting the first and the last line

    Options +FollowSymLinks
    Options -Indexes

    I hope that this will be useful to other developers.

    Thank you for your support and for your job. It's a great product!

  • edited 4:06AM
    Hello all,

    After making all of the suggested changes, the installation is not working for me (*sigh*). On both my server directory where I installed the .htaccess file, fuel and access folders (, and localhost/index.php/fuel, I'm getting a 404 Not Found error!

    I'm fairly new to all of this server config stuff, as I am a Web Designer with little experience dealing with the backend. I want to learn, but need to learn fast!!!

    FYI...I'm running Mac OS X Snow Leopard, and I'm using MAMP to manage Apache and MySQL. One thing I noticed in MAMP, is that while MySQL is running, Apache is not. Here's the kicker, when I load http://localhost, "It works!".

    Dazed and confused...needing a hand to hold.

    Thanks in advance!

    - B
  • edited 4:06AM
    Did you turn the admin on in the fuel/application/config/MY_fuel.php file?
  • edited 4:06AM
    Yes, it's set to TRUE.
  • edited 4:06AM
    Are you able to create a normal CI controller and browse to it OK (for more on that you can go here, if not familiar with CI):
    <?php class Test extends CI_Controller { public function index() { echo 'Hello World!'; } } ?>

    For example, you create a controller named test with an index method and are able to browse to it either by localhost/index.php/test or localhost/test (if .htaccess is working).
  • edited 4:06AM
    So I made some progress. I think!

    I did a re-install, following the same steps, and I'm no longer getting the previous 404 Not Found error. However, I'm now getting a message indicating a Database Error:

    //A Database Error Occurred
    //Unable to connect to your database server using the provided settings.
    //Filename: third_party/fuel/Loader.php
    //Line Number: 134

    I can't locate the file that it's referencing. And I'm using the same info to connect to my DB that I used when installing CI, in the database.php file.

    Any ideas what's causing this? Here's the URI being generated:

    Thanks again!
  • edited 4:06AM
    Didn't see your question re: CI controller. Let me give that a try.
Sign In or Register to comment.