Blog Module Route

edited November 2017 in Modules
I was new to fuelcms and still exploring the Blog Module. I have change the blog route from http://localhost/fuel/blog to http://localhost/fuel/news-feed and it works.

However, I wasn't able to change this url:
http://localhost/fuel/blog/2017/11/25/Camp-has-a-new-leader
to this:
http://localhost/fuel/news-feed/2017/11/25/Camp-has-a-new-leader
This is my fuel/application/config/routes.php:
$route['news-feed'] = 'blog'; $route['news-feed(/.+)?'] = 'blog/$1';
And this is the uri Setting for blog module (fuel/modules/blog/config/blog.php):
$config['blog']['uri'] = 'news-feed';
Am I missing something here? It would be great if anyone can help.

Comments

  • edited 2:57PM
    The $config['blog']['uri'] config should be where that URI change is made. Is it possible that there is a saved setting in the admin under Settings > Blog?
  • edited 2:57PM
    ah, I see. I should change that uri in the cms blog setting too, and it works.
    I thought that I don't have to change that uri in cms blog setting, since I have a config in fuel/modules/blog/config/blog.php:
    $config['blog_use_db_table_settings'] = FALSE;
    Thanks, admin.
  • edited 2:57PM
    It's actually the opposite. Defaults are in files and they can be overwritten in the CMS.
Sign In or Register to comment.