Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Error in web hosting

edited September 2017 in Installation
i received this error when i upload my project in the web host site.

Severity: Warning

Message: require(/hsphere/local/home/c94287/vcompass.com.ph/vcompass/fuel/modules/fuel/core/Ci.php): failed to open stream: No such file or directory

Filename: core/Loader.php

Line Number: 985

Comments

  • Is the file there? Does it have the correct permissions?
  • edited 5:12AM
    hi, where can i get the CI.php i cant find the file even in the fuelcms
  • edited 5:12AM
    i already copy that file that came from the third_party folder. and even the other file that said is missing but still im getting error upon loading the homepage. do you have a sample of httacess for web hosting environment?
  • edited 5:12AM
    Does it work if you apply this fix (I just pushed to the develop branch)?
    https://github.com/daylightstudio/FUEL-CMS/commit/ab0170b48275224c6743c0ca2e2bf2a392d23673
  • edited 5:12AM
    hi admin,

    thanks . i did the fix but i got this new error

    A PHP Error was encountered

    Severity: Error

    Message: Class 'CI' not found

    Filename: core/Loader.php

    Line Number: 77

    Backtrace:
  • edited 5:12AM
    I've never seen this error before. What's the full backtrace?
  • edited 5:12AM
    hi admin

    this is all in the screen.. backtrace is blank


    Fatal error: Class 'CI' not found in /hsphere/local/home/c94287/...../.../fuel/modules/fuel/core/Loader.php on line 77
    A PHP Error was encountered

    Severity: Error

    Message: Class 'CI' not found

    Filename: core/Loader.php

    Line Number: 77

    Backtrace:
  • edited 5:12AM
    And it works locally for you but not on the server? What are the specs locally vs. the server?
  • edited 5:12AM
    yes on my local its working not on the server
  • edited 5:12AM
    this is the specs on the web hosting site.

    We have MySQL 5.1 on all the shared hosting plans. As for Apache, it's Apache 2.2.

    And supported PHP versions are 5.2, 5.3, 5.4, 5.5, 5.6.
  • edited 5:12AM
    What version of PHP is running on the instance on the server (only one of those is running)? You can use the phpinfo() or phpversion() functions.
  • edited 5:12AM
    hi its PHP Version 5.5.38
  • edited 5:12AM
    Is this error if you navigate to any page or a specific URI?
  • edited 5:12AM
    upon loading of the page on the home page..

    but know. i have this error.

    Non-existent class: CI_User_agent
  • edited 5:12AM
    There seems to be something strange going on with your server and I'm not able to debug it from here unfortunately.
Sign In or Register to comment.