Advanced module permissions

edited July 2017 in Modules
I've got an advanced module, with several sub models. When I add permissions to the permissions table, I use the parent Module as a prefix, then the model name for the description eg Education: Media types Then the name is the path to the model, in this case "education/media_types". When I have created all 4 sub models in this way, other users not only cannot see the module (even if they are assigned), but the list of permissions under the user details for this module is not a tree - just a flat list. How can I make this like the Blog module, where each model is nested?


  • edited 9:27AM
    Is there a permission for the advance module itself of "education"?
  • edited 9:27AM
    OK I've done that (thought I had already!) and now there is a tree of permissions as expected. But even if users have all these enabled, when logged in as them, the module is not visible in the left menu?
  • edited 9:27AM
    Try adding nav options to the advanced modules config file as seen on the top of this page
  • edited 9:27AM
    I solved it. The permission key in each modules config was simply the name of the model, not the parent module + model! eg 'media_type' not 'education/media_types'.

    Thanks for your advice!
Sign In or Register to comment.