Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Final step in Getting Started leads to 404

edited February 2017 in Installation
Hi,

I am trying to install Fuel CMS. I use PHP5 on Ubuntu 14.

I was following the steps 1, 2, and 3 in the Getting Started. Everything seems to be okay, but when it tells me to goto http://localhost/fuel, it redirects me to http://localhost/fuel/start and gives me a 404 error.

I already tried searching for solutions but had no success. I'm hoping somebody here can shed some light.

My /var/www/ is like this:
.
├── assets
│   ├── cache
│   │   └── index.html
│   ├── css
│   │   ├── blog.css
│   │   ├── common.css
│   │   ├── main.css
│   │   └── reset.css
│   ├── docs
│   │   └── index.html
│   ├── images
│   │   └── index.html
│   ├── js
│   │   ├── jquery.js
│   │   └── main.js
│   ├── pdf
│   │   └── index.html
│   └── swf
│   └── index.html
├── fuel
│   ├── application
│   │   ├── cache
│   │   ├── config
│   │   ├── controllers
│   │   ├── core
│   │   ├── errors
│   │   ├── helpers
│   │   ├── hooks
│   │   ├── index.html
│   │   ├── language
│   │   ├── libraries
│   │   ├── logs
│   │   ├── migrations
│   │   ├── models
│   │   ├── third_party
│   │   └── views
│   ├── codeigniter
│   │   ├── core
│   │   ├── database
│   │   ├── fonts
│   │   ├── helpers
│   │   ├── index.html
│   │   ├── language
│   │   └── libraries
│   ├── data_backup
│   │   └── index.html
│   ├── index.php
│   ├── install
│   │   ├── archive
│   │   ├── fuel_schema.sql
│   │   └── upgrades
│   ├── licenses
│   │   ├── codeigniter_license.txt
│   │   └── fuel_license.txt
│   ├── modules
│   │   ├── fuel
│   │   └── index.html
│   └── scripts
├── html
│   └── index.html
├── index.php
├── info.php
├── README.md
└── robots.txt

and my .htaccess is like this

Options +FollowSymLinks


RewriteEngine On
RewriteBase /

#
# Order Deny,Allow
# Deny From All
#

# Allow asset folders through
RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

# Protect application and system files from being viewed
RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .* index.php?/$0 [L]

# Prevents access to dot files (.git, .htaccess) - security.
RewriteCond %{SCRIPT_FILENAME} -d
RewriteCond %{SCRIPT_FILENAME} -f
RewriteRule "(^|/)\." - [F]


Options -Indexes

Comments

  • edited 2:36AM
    Did you change the "admin_enabled" in the fuel/application/config/MY_fuel.php?
    // whether the admin backend is enabled or not $config['admin_enabled'] = TRUE;
  • edited 2:36AM
    Yes.


    // In MY_fuel.php...
    $config['admin_enabled'] = TRUE;
    $config['fuel_mode'] = 'AUTO';

    // In config.php
    $config['index_page'] = '';
    $config['uri_protocol'] = 'AUTO';


    phpinfo() says that mod_rewrite is loaded.

    I switched the rewrite rule back to ...

    RewriteRule .* index.php/$0 [L]

    ... and tried going to localhost/index.php/fuel/. I got redirected to http://localhost:8080/fuel/login/5a6e566c62413d3d. But then, I tried in config.php...


    // In config.php
    $config['index_page'] = 'index.php?';


    and when trying localhost/index.php/fuel, I got redirected to http://localhost:8080/index.php?/fuel/login/5a6e566c62413d3d and I see a login page.

    However, going to localhost/fuel/start still gives me 404. This is my first time with Fuel CMS and CI so I'm not sure what just happened.
  • edited 2:36AM
    doing this...

    // In config.php
    $config['index_page'] = 'index.php';

    gives the same result (seeing the login page), except that the redirected URL doesn't have the '?'.
  • This is my .htaccess for Ubuntu 14.04
    Options +FollowSymLinks <IfModule mod_rewrite.c> RewriteEngine On # RewriteBase / <Files .*> Order Deny,Allow Deny From All </Files> # Allow asset folders through RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L] # Protect application and system files from being viewed RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule .* index.php/$0 [L] # RewriteRule ^(.*)$ index.php/$1 [L] # Prevents access to dot files (.git, .htaccess) - security. RewriteCond %{SCRIPT_FILENAME} -d RewriteCond %{SCRIPT_FILENAME} -f RewriteRule "(^|/)\." - [F] </IfModule> Options -Indexes
  • edited 2:36AM
    Is .htaccess control enabled for that folder?
Sign In or Register to comment.