Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Blog Module Front End

edited November 2016 in Modules
I installed FUEL CMS and I installed Blog module. I added some posts to my blog from the admin end but I cannot view my posts from the front end.
When localhost/myproject/blog it redirects to the 404 page. Is there anything I need to do to make my posts accessible from the front end?

The version of my fuel and blog are
'FUEL_VERSION', '1.3.2' and 'BLOG_VERSION', '1.1'.

Comments

  • edited 11:08AM
    I think this long thread my be the answer you need. You'll need to probably lowercase the controller and model names in the fuel/modules/blog/models and fuel/modules/blog/controllers folder. This is due to the develop version of FUEL using CI 3.0 and requiring those files to be upper cased and CI 1.3.2 still being on CI 2. https://github.com/daylightstudio/FUEL-CMS-Blog-Module/issues/23
  • edited 11:08AM
    Thank you. Changing the all the controllers and models filenames to lowercase solved the problem.

    I however tried to change the the front end URL to localhost/myproject/myblog. I entered myblog in the URI field of the Blog settings, but localhost/myproject/myblog is not loading.
    Please am I missing something?
  • edited 11:08AM
    You'll need to add a route to your fuel/application/routes.php file something like:
    $route['myblog(/.+)?'] = 'blog/$1';
Sign In or Register to comment.