Setup database fail

edited December 2015 in Installation

When I try import in phpMyAdmin the file "fuel/install/fuel_schema.sql" it print this output:


SELECT `comment`
FROM `phpmyadmin`.`pma__column_info`
WHERE db_name = 'fueldb'
AND table_name = ''
AND column_name = '(db_comment)'

#1100 - Table 'pma__column_info' was not locked with LOCK TABLES

I'm in local with EasyPHP setup.

How to solve that?

Thank you!


  • edited 3:31AM
    Do you have a database setup yet to import the schema?
  • edited 3:31AM
    Database exist, utf8_general_ci collate, named fueldb

    Now it shows me this:
    SELECT MAX(version) FROM `phpmyadmin`.`pma__tracking` WHERE `db_name` = 'fueldb' AND `table_name` = 'fuel_permissions' AND FIND_IN_SET('INSERT',tracking) > 0

    #1100 - Table 'pma__tracking' was not locked with LOCK TABLES

    Seems same error with different query.
    I should do other before import?
  • edited 3:31AM
    Did you use the fuel/install/fuel_schema.sql file to import into fueldb?
  • edited 3:31AM
    Sure, as writed in first post I've tried to import this sql both using phpmyadmin upload and by copy/paste its content in sql page. It insert some tables in fueldb, but also show red error with the info posted above.
  • edited 3:31AM
    I think there is something with your phpMyAdmin setup. I just downloaded the latest version of phpMyAdmin and had no issues. See this Stackoverflow potential solution:
  • edited 3:31AM
    Ok, in webserver it works. But now there are htaccess errors, it return me error 500. If I remove .htaccess it load index.php... But all the system will work without it?
  • edited 3:31AM
    You will need to add index.php to the index_page config parameter in fuel/application/config/config.php:
    $config['index_page'] = 'index.php';
  • edited 3:31AM
    Tried it after reading install page, but seems there are no differences. Or I can delete htaccess with this parameter?
  • edited 3:31AM
    You would need to remove the .htaccess file if you don't want to use it. Is .htaccess with the mod_rewrite module even installed on the server? Also, are there certain things it doesn't like such as Options +FollowSymLinks or Options -Indexes ?
Sign In or Register to comment.