Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

3rd Party Integration ?

edited April 2011 in Modules
OK.

I can read on the home page the following:

"One click login into other 3rd part applications like Google Analytics, Clicky, Wordpress and phpMyAdmin."

I can find 'google analytics' helper and that's cool...
but..

how about 'clicky' , wordrpess helper (has been removed?), and phpMyAdmin ??

Would it be possible to include it out of the box when downloading CMS or at least create some kind of quide how to include above functionality?

PS Great work with CMS.... love it so far!

Comments

  • edited 2:49PM
    Good point. I removed them from the initial installation and have been debating on where to put them. I've decided to create a new Modules Pack for folks to download which includes those modules as well. The GA, WP, and phpMyAdmin, are links that submit form values to log you in to the associated admins. This helps you centralize your admin functionality.
    https://github.com/daylightstudio/FUEL-CMS-Modules-Pack
  • edited 2:49PM
    great thanks!

    campaign monitor language file is cousing an error.... other then taht great !!!

    Should we put it under the documentation then? How to enable then in the admin panel etc.
  • edited 2:49PM
    Does that error go away if you change line 19 in the controller to?
    $this->load->module_language(CAMPAIGN_MONITOR_FOLDER, 'campaign_monitor');
    The README has the installation instructions. I plan on doing a more official blog post when I have some time.
  • edited 2:49PM
    It is still complaining... ;/

    /Volumes/STORAGE/Sites/fuelcms/fuel/application/../modules/campaign_monitor/language/english/campaign_monitor_lang.php does not contain a valid lang array

    When i look inside the file... nothing is there...
  • edited 2:49PM
    Ahh... OK. That should be fixed now.
  • edited August 2011
    Am using 0.9.3.
    Have a client who wants me to install Wordpress for use as an image gallery with categories, etc. I've installed it in a 'wordpress' folder. I downloaded the 3rd party modules and placed the wordpress folder from the 3rd party modules zip into the fuel/modules/ folder. Then did the following:

    In application/config/MY_fuel.php I added 'wordpress' to the $config['modules_allowed'] array.

    In fuel/modules/fuel/config/fuel.php I added 'wordpress':
    // dashboard modules to include
    $config['dashboards'] = array('fuel', 'backup', 'wordpress');

    fuel/modules/wordpress/config/wordpress.php is set up like this (with the real data of course):$config['wordpress'] = array(); $config['wordpress']['url'] = 'http://thedomain.com/wordpress/'; // just the base url $config['wordpress']['login'] = 'username'; $config['wordpress']['pwd'] = 'password'; $config['wordpress']['permission'] = 'wordpress';
    fuel/modules/wordpress/config/wordpress_constants.php is this:define('WORDPRESS_VERSION', '3.1.1'); define('WORDPRESS_FOLDER', 'wordpress'); define('WORDPRESS_PATH', APPPATH.MODULES_FOLDER.'/'.WORDPRESS_FOLDER.'/');fuel/modules/wordpress/config/wordpress_routes.php is unchanged:$route[FUEL_FOLDER.'/wordpress/dashboard'] = WORDPRESS_FOLDER.'/dashboard'; $route[FUEL_FOLDER.'/wordpress'] = WORDPRESS_FOLDER;
    The others are also unchanged.

    When I'm logged in to the CMS I see a link that says 'login' next to a wordpress icon which shows up just under the 'Latest Activity' list in the main content area of the CMS. When I click the link a new window opens to the home page of wordpress but the CMS user is not logged in to Wordpress. Is that what's supposed to happen? From there the user would have to log in to Wordpress rather than the login being passed to wordpress. My understanding was that the idea was to have a singular login area for both.
  • edited 2:49PM
    I think you need to add /wp-admin to the url parameter.
  • edited August 2011
    Ok. I changed it to:
    $config['wordpress']['url'] = 'http://testsite.com/wordpress/wp-admin'; // just the base urlIt's sending me to the login page now but here's what I'm seeing in the url querystring:
    wordpress/wp-login.php?redirect_to=http%3A%2F%2Fdev.testsite.com%2Fwordpress%2Fwp-admin%2F&reauth=1
    It's not logging the user in. Also, btw, I updated Wordpress to 3.2.1. You think that might have anything to do with it?
Sign In or Register to comment.