Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

assets in editor issue

edited July 2015 in Bug Reports
Hi,
uploading in fuel/assets seems be ok, but it does not work in wysiwyg editor. After submitting image upload form I get message "Data has been saved.", but in editor I have src="{img_path('null')}".

Although I have files in assets, in wysiwyg editor asset_select is always empty.

Any ideas? (In console I do not have any error and no idea how to debug it)

btw. I found fuelcms today and it looks really great! ;) thanks for that

Comments

  • edited July 2015
    A few questions:
    1. How big of a file are you uploading?
    2. Is the assets/images folders writable?
    3. Is the wysiwyg editor markitUp! (the default), or CKEditor?
    4. Is this in the Pages modules or your own simple module?
    5. This is with the most latest version of FUEL 1.3(can test by looking at the fuel/modules/fuel/config/fuel_constants.php)?
  • edited July 2015
    1. if I upload big file, I will get normal error
    2. yes, assets/images is full of my uploaded files. everything I upload there goes, but I just can not access to these files in editor. select name="asset_select" is always empty.
    and I dont get right url to image has src="{img_path('null')}"
    3. same problem with both
    4. pages, blog, blocks, anywhere
    5. yes, pure new version tested on localhost and domain/webhosting
    I tried once again with new unzipped downloaded fuel, same problem :/

    Adding image while in assets folder and subfolder has many uploaded files: http://oi57.tinypic.com/oavnno.jpg
  • edited 11:34PM
    In the console, what is the full URL path that it is using for the content in that modal window (it's an iframe that loads a URL)? It should say if it's trying to go to a sub folder or not. What permissions do you have set on your images folder?
  • edited 11:34PM
    Console is everywhere empty, 777.
    /fuel/assets/select/images?nocache=[somenumber]&width=&height=&alt=&align=&class=&order=
    then
    /fuel/assets/inline_create?asset_folder=images...
  • edited 11:34PM
    I'm not sure why you aren't seeing any of the images in that folder in the dropdown if it is writable. Are any files listed in the fuel_assets_model::list_items method around the following lines (121):
    $tmpfiles = directory_to_array($assets_path, TRUE, $exclude, FALSE); $files = get_dir_file_info($assets_path, FALSE, TRUE);
  • edited July 2015
    in url /fuel/assets/items... $tmpfiles is full of images
    but in url /fuel/assets/select/images... only if I change path for example $assets_path .= "docs"; - but images dont show
    I tried debug it with checking values of many variables, but I am somehow lost :D
    I will download older version and let you know.
    Thank you
  • edited July 2015
    ok, 1.2.1 works well. now I know how it should look :D

    //edit
    I just added /images folder to assets and it works well. I can not view other folders in folder, but better than nothing, finally.
    thanks

    //
    sory you asked if assets/images was writable, I did not realize that among folders in assets was not /images but docs, pdf... and some new of mine
Sign In or Register to comment.