Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Installation problem

edited March 2011 in Installation
Step 1., Step 2. I have copied FuelCMS (v0.9.3-12) into my virtual server.¨
File structure as I unzip downloaded files. All files under Fuel folder. Assests, index.php, .httacess in root.
Step 3. Browse to www.zkusto.cz (ERROR: Fatal error: Class 'CI_Controller' not found in /data/www/virtuals/zkustocz/html/fuel/codeigniter/core/CodeIgniter.php on line 217)

Error on line 217 should be on 210 to, it moves to 217 after I copied newest codeigniter 2 to codeigniter folder.

I am not sure where I am wrong, but it should be something with my installation order, because I had the same problems on my another webhostings.

What is the problem? Codeignitor 2, it self, works fine.

Comments

  • edited 9:16AM
    Within the downloaded folder, there should be an .htaccess, assets, index.php, README, and a fuel folder that has the application, codeigniter, modules etc. in it. You should be able to put that entire structure into your web's root directory and an installation page should show up. Are you seeing that?
  • edited 9:16AM
    Yes I have this file structure. But installation page not show up.

    Only error "Fatal error: Class 'CI_Controller' not found in /data/www/virtuals/zkustocz/html/fuel/codeigniter/core/CodeIgniter.php on line 210"

    Here is my server php info:
    http://zkusto.cz/info.php
  • edited 9:16AM
    Can you try downloading the latest from GitHub and take the entire contents of the folder and put it on a webserver without upgrading the CI 2? If you install it in a subfolder say called "test" then the URL would be something like http://zkusto.cz/test/. You should see the installation instruction page.
  • edited 9:16AM
    No change. Only in path to CodeIgniter.php file.

    Fatal error: Class 'CI_Controller' not found in /data/www/virtuals/zkustocz/html/test/fuel/codeigniter/core/CodeIgniter.php on line 210
  • edited 9:16AM
    That is strange. If you look at that file, you'll see a require BASEPATH.'core/Controller'.EXT; right above it. That file should contain the CI_Controller class. Do you see that class in that file?
  • edited 9:16AM
    Yes, this is the one class defined in Controller.php

    I know, that this is strange. But all seems ok, but it does not work.
    I can send you ftp info.
  • edited 9:16AM
    OK... why don't you do that when you have time. I'd like to know what the issue is. My email address can be found on my profile.
  • edited 9:16AM
    As this looks similar insofar as my install error(s) should not happen...

    Just to check if something was amiss I created three folders and copied the contents of git to each... I then tried to browse each folder and got three different error reports...

    1st: Cannot redeclare class ci_lang in C:\wamp\www\fuelcms\fuel\codeigniter\core\CodeIgniter.php on line 227

    2nd: Call to undefined function get_filenames() in C:\wamp\www\fuelcms2\fuel\modules\fuel\libraries\Fuel_layouts.php on line 48

    3rd: I got the Welcome page.... but when I try to access http://127.0.0.1/fuelcms3/fuel, it brings me to my wamp index....

    Windows7, Wamp 2.1, Apache Version 2.2.17, PHP 5.3.5 and MySQL 5.5.8...
  • edited 9:16AM
    Disregard the first two test installs, I may have had a problem on my side...

    The third install error remain...
  • edited 9:16AM
    Is the admin "enabled" config parameter set to TRUE in your fuel/application/config/MY_fuel.php?
  • edited 9:16AM
    Yes...
  • edited November 2011
    Added index.php to $config['index_page'] ... and it worked...
    I could have sworn I have mod rewrite on?

    It looks seriously nice.... sorry fot the bother...
    Mike
    Oops... just noticed the edit option...
  • Parse error: parse error in C:\xampp\htdocs\FUEL-CMS-master\fuel\codeigniter\core\CodeIgniter.php on line 58

Sign In or Register to comment.