Chrome and strict MIME checking

edited March 2015 in Installation
Chrome (only) is refusing a cached js asset (a PHP file) in a Fuel site with the message:
Refused to execute script from 'http://somesite.com/assets/cache/17fca40a215ef24608713322b33f3595_-62179984000.php' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled
Unfortunately it is the main Bootstrap file. Is this something that should be addressed by .htaccess or by the caching process? I've set the asset output to FALSE to remove this issue for now, but it would be nice to address it somehow.

Comments

  • edited 6:18AM
    I believe that error is because the file is PHP and it's serving up CSS but as a PHP file. It's required to be a PHP file to execute the gzipping that is outputted. You can change the setting to just "whitespace" which won't turn it into a PHP file and will leave it as "css". Or you may need to make some changes the server such as using .htaccess to remove that error and allow PHP to serve up css and js files that are compressed and gzipped.
  • edited 6:18AM
    Actually it was a js file - but I will try "whitespace" - thanks
Sign In or Register to comment.