Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Fresh install Issues

edited December 2010 in Installation
Hi I have just done a fresh install of fuel CMS version 0.91.
And i can't view the admin area i get this: FORBIDDEN - You don't have permission to access /_fuelcms/fuel/ on this server.
i have the .htaccess set to: RewriteBase /_fuelcms/

the FCPATH output is: /Applications/MAMP/htdocs/_fuelcms/

Can you help me out, thanks.

Comments

  • edited 1:51AM
    That sounds like an Apache specific error. Are you sure mod_rewrite is enabled on your server?
  • edited December 2010
    Here is what i get with my clean install at work.

    FCPATH: C:\xampp\htdocs\fuel\


    Notice: Undefined offset: -1 in C:\xampp\htdocs\fuel\fuel\modules\fuel\config\fuel_constants.php on line 14

    again when i go to here: http://127.0.0.1/fuel/fuel/

    i get this:
    Access forbidden!

    You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

    If you think this is a server error, please contact the webmaster.
    Error 403

    Yes, mod_rewrite is active and working fine with other sites.
  • edited December 2010
    Sorry for the delay in getting back to you.
    The FCPATH should include index.php at the end like so. C:\xampp\htdocs\fuel\index.php

    CodeIgniter sets that constant on line 94 in the index.php bootstrap file. I'll need to do a little research into why
    define('FCPATH', __FILE__);
    does not return index.php as part of the path. Are you by chance using fast-cgi for your php instead of the Apache module (phpinfo() should tell you)?
  • edited 1:51AM
    Not using fast-cgi
  • edited 1:51AM
  • edited December 2010
    ok, so i deleted everything and started again - fresh install.

    My Setup:
    - Using xampp
    - Mod_rewrite active and working fine.
    - Windows System
    - PHP 5 & MySQL 5
    - Apache 2
    - NO Fast-CGI

    Site location: C:\xampp\htdocs\fuelcms\
    ----------------------------------------------------------------------

    Install Problems:

    1. Type in: http://127.0.0.1/fuelcms/index.php/

    I get FCPATH: C:\xampp\htdocs\fuelcms\

    I get the Welcome to FUEL CMS page, but above the logo and title i have this:

    Notice: Undefined offset: -1 in C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php on line 15

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    -------------------------------------------------------------------

    2. Type in: http://127.0.0.1/fuelcms/index.php/fuel/login, and i get this:

    I get FCPATH: http://127.0.0.1/fuelcms/index.php/fuel/login

    I get the Login Box, but above this i have this:

    Notice: Undefined offset: -1 in C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php on line 13

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    -------------------------------------------------------------------

    3. Once logged in i see only errors like this:

    Notice: Undefined offset: -1 in C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php on line 13

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: libraries/Session.php
    Line Number: 670

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: core/Input.php
    Line Number: 226

    A PHP Error was encountered
    Severity: Warning

    Message: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\fuelcms\fuel\modules\fuel\config\fuel_constants.php:13)

    Filename: helpers/url_helper.php
    Line Number: 54

    -------------------------------------------------------------------
    The info for database.php file have been added, and in the config/MY_fuel.php file just these have been changed: $config['admin_enabled'] = TRUE; and $config['fuel_mode'] = 'auto';.

    No other fuel settings have been touch just pasted in folder and viewed.
  • edited 1:51AM
    OK... I'll download XAMPP and try it out (I have WAMP for my windows test server)
  • edited December 2010
    hi again

    i removed xampp and installed WAMP and it works!

    The only thing i keep getting is this:
    Notice: Undefined offset: -1 in C:\wamp\www\fuelcms\fuel\modules\fuel\config\fuel_constants.php on line 12

    And in config.php if i remove $config['index_page'] = ""; with mod_rewrite active it won't work, just goes back to wamp homepage. or i get Forbidden message.
  • edited 1:51AM
    I found the issue (and a few others I'm cleaning up). FCPATH is different between CI 1.72 and CI 2.0. I'm hoping to do a post later tonight to address that and some issues found with regards to assets. Also, make sure you set the $config['admin_enabled'] = TRUE; in fuel/application/config/MY_fuel.php. Thanks for your patience.
  • edited December 2010
    The fixes have been pushed to GitHub for you to test out:
    https://github.com/daylightstudio/FUEL-CMS/tree/0.91
  • edited 1:51AM
    Awesome update fixed issues. Thanks heaps david.
  • edited 1:51AM
    Sure, let me know if you run into any other issues.
  • edited 1:51AM
    I have problem with created page. i created page with location test but i get 404 while browsing http://localhost/fuel/test
    Admin area at http://localhost/fuel/fuel is working. any thoughts?
  • edited December 2010
    Make sure the $config['fuel_mode'] = "auto" in the fuel/application/config/MY_fuel.php. Also make sure that you have mod_rewrite enabled and the proper RewriteBase value which should be the folder relative to the web root directory.
  • edited 1:51AM
    Hi

    still can't get it working. config.php there wasn't fuel_mode value at all. i added it, but no success. fuel is installed in fuel dir relative to webservers root

    Options +FollowSymLinks

    RewriteEngine On
    RewriteBase /fuel

    why i can't get this working?

    in admin->pages when i click view (http://localhost/fuel/fuel/pages/view/1) i get transfered to http://localhost/fuel/test

    http://localhost/fuel/ displays welcome message with getting stated guide
  • edited 1:51AM
    My mistake above. I originally gave you the path to the regular config file (and have since corrected it to the fuel/application/config/MY_fuel.php config file). Sorry about that. Also, I don't know if it matters or not, but I'd add the slash at the end of the RewriteBase (e.g. /fuel/). Lastly, if you are still having problems, there is another thread that may help.
    http://getfuelcms.com/forums/discussion/3/problems-with-.htaccess-and-404-dashboard-not-found/#Item_18
  • edited 1:51AM
    MY_fuel helped.
Sign In or Register to comment.