Language problem

I get this when I set my language in mi profile.

Severity: Notice

Message: Undefined property: Fuel::$language

Filename: helpers/MY_url_helper.php

Line Number: 58



  • edited 12:01AM
    A couple questions for you:
    1. What do you mean by mi profile?
    2. What version of FUEL are you using?
  • edited 12:01AM
    My admin account. I also don´t see the pages, I use this <?=fuel_var('body', '')?> and this <?php echo fuel_var('body', ''); ?>, or this <?php echo fuel_var('layout', ''); ?> in the main layout, with the fuel_mode = auto. I use version 1.2.

    I also tried to use the codes so users can change language on the page but none of them seems to do anything.

    Thanks for your time.
  • edited 12:01AM
    You'll need to be more specific in your problem.
    1. What are the URI paths of the pages you are talking about?
    2. Did you create these pages in the CMS or as static view files?
    3. Do you have multiple language settings set for the site:
  • edited 12:01AM

    These are made with de cms page, thay are transalated just changing the language selector in the page, but I really have the problem with any page, as I wrote in the the other message I try this, <?=fuel_var('body', '')?> and this <?php echo fuel_var('body', ''); ?>, or this <?php echo fuel_var('layout', ''); ?>

    2. Yes, I create the pages in the cms.

    3. I have multiple languages.


    $config['languages'] = array(
    'english' => 'English',
    'es' => 'Spanish',
    'cat' => 'Catalan',

    // the default language to use
    $config['language_default_option'] = 'spanish';


    $config['language'] = 'spanish'; ( I tried this with 'spanish', 'english')

    The folders are created in fuel/module/fuel/language

    When I solve this I would like to contribute to finish the spanish translation or upgrade it to 1.2, I see is not upgraded since 4 years ago. And maybe if a friend helps me, to add Catalan.
  • edited 12:01AM
    Try changing the following configuration parameters:
    $config['language_default_option'] = 'es';

    And changing the language folder name to "es":
    $config['language'] = 'es';

    Regarding the translation, that would be great. Just let me know how I can help facilitate that.
Sign In or Register to comment.