Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Installation Problem - Can't Forward to /fuel/start

edited October 2014 in Installation
I've tried installing the most recent version of FUEL (cloned from github). I've followed the directions that appear, but upon trying to access XXX.XXX.XX.XX/fuel it tries to redirect me to /fuel/start which it cannot find. My base installation is at /var/www/FUEL-CMS. This is setup as my apache root. It appears that this file exists, but while /fuel exists at /var/www/FUEL-CMS fuel/start only exists at /var/www/FUEL-CMS/fuel/modules/fuel/controllers/start.php. I'm imagining something is not right with the htaccess files, but I'm not quite sure as according to my understanding of codeigniter all of the files should be at /var/www/FUEL-CMS/application/controllers/*. My htaccess file in /var/www/FUEL-CMS looks like:

Options +FollowSymLinks


RewriteEngine On
RewriteBase /var/www/FUEL-CMS/


Order Deny,Allow
Deny From All


# Allow asset folders through
RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

# Protect application and system files from being viewed
RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .* index.php?/$0 [L]

# Prevents access to dot files (.git, .htaccess) - security.
RewriteCond %{SCRIPT_FILENAME} -d
RewriteCond %{SCRIPT_FILENAME} -f
RewriteRule "(^|/)\." - [F]


Options -Indexes


Making adjustments to this seems to directly affect my site, so it should be activated. This seems to be a common issue (https://github.com/daylightstudio/FUEL-CMS/issues/242), but their fix did not work for me. Thanks!

Comments

  • edited 9:16AM
    Your RewriteBase should be relative to the web root directory so try changing it to simply just /FUEL-CMS/
  • edited 9:16AM
    I changed it to /FUEL-CMS/ but the same problem persists
  • edited 9:16AM
    Try this one, this is the only htaccess that works for most of my codeigniter installations.

    Options +FollowSymLinks

    RewriteEngine On
    RewriteBase /FUEL-CMS (or whatever)

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule .* index.php?/$0 [L]
  • edited 9:16AM
    Note the question mark after index.php?

    This is a common configuration issue with CodeIgniter in general and .htaccess.
  • edited 9:16AM
    I've tried both the one provided by madredeuz, with and without the ? (seen below). I've also tried removing the ? from the previously posted htaccess file to no avail.

    What confuses me though is how would any of these forward me to the modules directory while simultaneously allowing the use of the typical codeigniter structure where the files are stored in /fuel/applications/controllers while the start.php file is located somewhere completely differently: /fuel/modules/fuel/controllers/start.php

    Options +FollowSymLinks


    RewriteEngine On
    RewriteBase /FUEL-CMS/

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule .* index.php?/$0 [L]


    Options -Indexes
  • edited 9:16AM
    There is a fuel/index.php file that has the redirect to the fuel/start controller file. Are you able to get a normal CodeIgniter installation to work with .htaccess?
  • edited 9:16AM
    Yea, typical CI installations have worked
  • edited 9:16AM
  • edited 9:16AM
    Seokse

    Do you own the server? Are you sure mod_rewrite is installed?

    Try just remarking out the RewriteBase line...
    # RewriteBase /
  • edited 9:16AM
    Actually, if your FUEL installation is in a "FUEL-CMS-master" folder, the RewriteBase should be:
    RewriteBase /FUEL-CMS-master/
    If that doesn't work, then you should check that mode_rewrite and .htaccess is enabled for your Apache server.
  • edited May 2015
    I had the same problem and wanted to post this in case anyone else runs into it.

    The thing that caught me out while setting up is that I had skipped the last step of the installation process, in fuel/application/config/MY_fuel.php you need to change this line to set the value to TRUE:
    $config['admin_enabled'] = FALSE;
    If you don't do this, the admin's controllers will all throw 404s.

    It seems to me that this is an easy mistake to make because the default view's install instructions seemed to always jumped to the bottom when they loaded, which implied to me somehow that these steps were complete (which wasn't true), so I only sort of skimmed them.
  • edited September 2015
    Just one glitch during install...
    Installed to 127.0.0.1/fuel-cms so .htaccess > RewriteBase should be "fuel-cms" ...
Sign In or Register to comment.