Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Inline Edit Button Not Showing

edited March 2011 in Bug Reports
Hi

I have used FUELCMS to create the website at http://www.redbrick.dcu.ie/~engsoc/, Version 0.9.2.

The edit pencil does not show up anywhere on my website even though I have used fuel_edit in numerous locations, 1 in header, 2 or 3 in footer and loads of others dotted around the site. The "Back to Admin" and "Logout" toolbar shows up and fuel adds some span classes for inline editing beside the items which editing is enabled on but the pencil is not showing up.

Any help would be greatly appreciated.

Comments

  • edited 2:29AM
    Is there a pencil icon button on the toolbar when you open it up? If not, would it be possible for you to send me a login so I can test out the inline editing (email can be found if you click on my profile image)?
  • edited March 2011
    There is only a pencil icon for pages loaded into fuel which I did just there, I didn't want to have to do it, but not on the others which are one controller and one static view file.

    I'll send you details now.
  • edited 2:29AM
    Hi, I have same problem, it only shows the fuel icon at the upper right hand corner.

    Take a look:
    http://airzonetest.magentadesigncorporation.com/

    Thanks in advanced.

    Best regards
  • edited 2:29AM
    For the pencil icons to show up, you need to either use the fuel_edit() function or the fuel_var() function to embed variables in your layout. Those functions do the extra work of writing the inline editing code which allows the pencil icons to appear. If there are no editable regions on the page, then the pencil icons will not appear. Are you pages created in the CMS? If so are you using something like the following in your layout to embed the variable?
    ... <?=fuel_var('body')?> ...
  • I have the same problem i.e. not being able to see any pencil icons on page, I did in some pages but don't remember how, I have a about-us page as key and its a CMS page, follows a layout and a variables file named same as key, I have defined an array $pages['about-us'] and the value is 'words' => 'Some words...'. I want this variable to be editable inline. It renders with the value in file but no pencil icon is shown even though I'm logged in as superuser rights.

  • @admin please see this post, what am I doing wrong, I really want to do it, I had another page with No Layout as Layout and applied html, when I see this page I also see the pencil icon although I have not applied any variables to it for editing.

  • Inline editing variables only apply to page variables created in the CMS and won't work for variables created in a variables file. Also, did you toggle the pencil icons on in the top menu bar on the page to show the pencils?

  • I clicked the pencil icon and it showed me menu for changing layout, page, variables in the No Layout page one, but nothing was shown in other pages. Where do I create page variables in CMS? Site Variables?

  • I have tried defining a variable using fuel_var and it shows with default value but unless I change my page layout to pre-built ones, I can't see the menu and use it to toggle inline editing. Why my layouts don't show this menu?

  • Was the page created in the CMS under the pages module?
    http://docs.getfuelcms.com/general/inline-editing

  • Yes it was created using Pages module

  • What does your layout look like and what fields are you using in your layout (MY_fuel_layouts.php)?

  • This is the layout which I am using in pages

    $config['layouts']['nt_basic'] = array(
        'fields' => array(
            'Header' => array(
                'type' => 'fieldset',
                'label' => 'Header',
                'class' => 'tab'
            ),
            'page_title' => array(
                'label' => lang('layout_field_page_title')
            ),
            'meta_description' => array(
                'label' => lang('layout_field_meta_description')
            ),
            'meta_keywords' => array(
                'label' => lang('layout_field_meta_keywords')
            ),
            'Body' => array(
                'type' => 'fieldset',
                'label' => 'Body',
                'class' => 'tab'
            ),
            'heading' => array(
                'label' => lang('layout_field_heading')
            ),
            'body' => array(
                'label' => lang('layout_field_body'),
                'type' => 'textarea',
                'description' => lang('layout_field_body_description')
            ),
            'body_class' => array(
                'label' => lang('layout_field_body_class')
            ),
        )
    );
    
  • And the fuel/application/views/_layouts/nt_basic.php layout file uses something like the following in it:

    <?=fuel_var('body')?>

    Additionally, you have a page in the CMS setup using that layout and the body field is filled out?

  • yes I have my complete website using this layout and defining page design in body in CMS page for every page.

  • Is there perhaps a PHP error or javascript error on the page (turn on errors in the /index.php bootstrap file if they are not on)

  • I removed all the content and only printed the value of $pages['page-slug']=array('words' => 'Some words...') defined in _variables/page-slug.php and checked the index.php which says if environment is development then errors are on so didn't did anything there and no errors are shown anywhere in page (php or js)

  • OK. So if you go into the CMS, and create a page with a location of test and select your nt_basic layout and fill out the "Body" field, does /test appear with the body text. If so, do you have the pencil icons appear on that page and is there one for 'body'?

  • I have a test page and did the same thing and yes body does come but no fuel icon on top-right corner where the pencil icon is also in that menu.

  • Is it perhaps hiding behind your header because of a z-index and are you logged into FUEL when viewing?

  • Nice, :smile: :smiley: I thought same thing and tried doing by removing header and footer and only keeping the fuel variable but no menu was there

  • @admin please tell me a solution for this???

  • I think I would need a URL and system access to fully determine your issue because I can't glean enough from your description. My profile has an email address in which you can send me information if you'd like.

  • So, to resolve the issue that I had been having.
    I contacted the admin on mail and he told me that I was missing tags for closing body and html and I was like whaaatt??? I had been like developing this for months and I was missing that much little detail? Turns out he was right and when I corrected my HTML, everything worked fine. I hope if you get in this issue then... you know where to look for.
    Again thanks @admin for such help, much love.

Sign In or Register to comment.