Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Having trouble getting cron working :s

edited May 2014 in Bug Reports
I have the cron module installed, but I'm having trouble getting curl jobs to run. LAMP box, other cron jobs on the server run fine, but I want to do this one through the website using the cron module so the client can adjust the timing of jobs as needed...they're not experienced enough to do it through ssh.

This is the command text:
curl http://mysite.com/task/geocode
No quotes around anything

It fails to run and I get emails that says:
curl: (7) couldn't connect to host

I added the IP of the server to MY_fuel.php like this:
$config['webhook_remote_ip'] = array('192.168.1.10'); /* I used my actual IP here not the IP listed */

Am I defining the command incorrectly?

Comments

  • edited 12:27AM
    Can you run that command via command line outside of the module and cron OK?
  • edited 12:27AM
    Don't have SSH access at the moment...working on that?
  • edited 12:27AM
    Stupid Plesk. I can't seem to figure out how to enable SSH access for my server, but I do know that the CRON jobs aren't running as root, so there may be permissions issues. The user is the FTP account.
  • edited 12:27AM
    HAha it ended up being a firewall issue. The client has a managed GoDaddy server so I don't have root access and they secure the hell out of the box. There was no rule for local http access through the firewall, LOL.

    My original cron command: curl http://mysite.com/task/geocode

    Works just fine now :)
Sign In or Register to comment.