base_url issue. . .maybe?

edited March 2011 in Installation
Is there any reason that I would see a double url when attempting to change my password from the admin panel?

For example I am able to see the dashboard which when I do there is a popup asking me to change my password and when I click "change password" I see something like the following:

http://example.com/fuelcms/index.php/example.com/fuelcms/example.com/fuelcms/index.php?/fuel/my_profile/edit

As you can see the Fuel cms is installed in a subfolder called fuelcms.

Please help?

Comments

  • edited 5:07AM
    Possibly. You could try hardcoding the $config['base_url'] value. FUEL tries to dynamically create that base_url. What's your uri_protocol set to in the CI config?

    This thread towards the end talks a little about fixing issues when the uri_protocol is query_string:
    http://www.getfuelcms.com/forums/discussion/comment/585/#Comment_585
  • edited 5:07AM
    uri_protocol was set to AUTO and just changed it to REQUEST_URI and nothing has changed so far. It looks like its automatically adding an extra example.com/fuelcms before the functional url.

    For example if I type in "example.com/fuelcms/index.php?/fuel" it directs to a 404 thusly http://example.com/fuelcms/example.com/fuelcms/index.php/fuel/login/5a6e566c62413d3d

    If I take out the first example.com/fuelcms then the login page loads.

    I'm looking at the other threads now to see if they help at all.
  • edited 5:07AM
    Maybe a good place to start would be to:
    1. Hard code in the base url in the fuel/application/config/config.php file
    2. Remove the .htaccess file (or comment out it's contents)
    3. Add index.php for the $config['index_page'] value in the fuel/application/config/config.php

    That get's you to the basic CI configuration that doesn't use .htaccess.
  • edited 5:07AM
    I had a problem like that with FUELCMS 0.9.1, try upgrading to 0.9.2.
  • edited 5:07AM
    Hello. I have an issue with login. Everytime I fill up login form I am redirected to itself.
    My website is located on subdomain japanautostar.petrunko.com which is stored in directory /subdomains/japanautostar/ on petrunko.com.

    .htaccess for petrunko.com looks like that:

    RewriteEngine On
    RewriteBase /

    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^(.*) http://%1/$1 [L,R=301]

    RewriteCond %{HTTP_HOST} ^(test|wiki|japanautostar)\.petrunko\.com$
    RewriteCond %{REQUEST_URI} !/subdomains/%1/
    RewriteRule ^(.*)$ /subdomains/%1/$1 [L,QSA]
    .htaccess in /subdomains/japanautostar/ folder looks like that:

    Options +FollowSymLinks

    RewriteEngine On
    RewriteBase /

    Order Deny,Allow
    Deny From All

    RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]
    RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .* index.php/$0 [L]

    RewriteCond %{SCRIPT_FILENAME} -d
    RewriteCond %{SCRIPT_FILENAME} -f
    RewriteRule "(^|/)\." - [F]

    Options -Indexes
    Can you help please? Login & password are like in new installation.
  • edited 5:07AM
    Does this problem happen on your local development or is this specific to the server?
  • edited 5:07AM
    I think this problem do not depend from server. I guess I should modify .htaccess for my subdomain to make it work, I've read Fuel CMS manual, tried few solutions, but neither is works. Do you have any idea what can cause this problem?
  • edited 5:07AM
    I'm sorry, but I don't at the moment. My only suggestion would be to try and isolate if it is a server environment or not. To do that, I'd recommend getting it setup in a different environment.
Sign In or Register to comment.