Problems gmaps v3 with fuel cms

edited January 2014 in Bug Reports
Hi, I import a static page I made before using gmaps v3 api. First, when I tried to load the page, the page displayed an error saying "compilation error: parse error" in a line of the javascript I was using from gmaps api.

Then, inspite of having the code in the body of the page, I made a file and I was loading that file in the header. There was no more displayed errors, the site loaded, but it wasn't displaying the map.

I check everything, I check that I was calling the api of gmaps correctly, I check the position when I was calling it (before my file), I started to compare line per line with the other site with my map working, I compared the css, js, and even the body, everything was the same but it was not displaying the map.

I'm not using php in that page, so, in the meantime, if I save the page as .html (I'm not using here anything of fuel) instead of .php with and I save it in my root, I can access with the following url: mydomain.com/map.html and everything is working.

But I really would like manage this page through the cms. So I wonder if somebody knows why my map is not displayed if I make the page with fuel cms.

Comments

  • edited January 2014
    Usually those errors have to do with the Dwoo compiling javascript code. One way to avoid that is to add a space after any { in the javascript. You can also wrap the javascript with:
    <literal></literal> which will tell Dwoo to avoid processing the templating code.
  • edited 8:09AM
    Hi, thank you for your response. I added an space after every { and there is no more compilation error, however my map is still not loading. I wrap it too with "" and the same result. Do you know anything else I can try?
  • edited 8:09AM
    My literal tag didn't come through above... the "" should have been the following:
    <literal></literal>
Sign In or Register to comment.