Setting Up Fuel in WAMP

edited September 2013 in Installation
Hello everyone. Even though I'm somewhat familiar with MVC (Zend in particular), I'm still somewhat a novice in setting things up. I'm sure I have my Fuel files in the right location. When I type in the domain name "http://domain", it tries to go to "http://domain/dashboard" where it says that it isn't found. I'm sure it has something to do with routing. Can someone please advise? Thanks


  • edited 7:01AM
    If you are wanting to get to the FUEL dashboard, you'll need to add "fuel" in the path like so:

    If you are having trouble with that, make sure that the admin is enabled in the fuel/application/config/MY_fuel.php file (as per the installation instructions) and that you have .htaccess working. One way to check without .htaccess is to include the index.php bootstrap file in the path like so:
  • edited 7:01AM
    Thanks for replying. I'm still having issues.

    Here is my directory setup.

    /projectname (http://projectname)


    /application (and all the files that came in this folder with fuel)
    /codeigniter (and all the files that came in this folder with fuel)
    /crons (and all the files that came in this folder with fuel)
    /data_backup (and all the files that came in this folder with fuel)
    /install (and all the files that came in this folder with fuel)
    /licenses (and all the files that came in this folder with fuel)
    /modules (and all the files that came in this folder with fuel)

    I already setup the database. Admin is enabled already with $config['admin_enabled'] set to TRUE in the config file in 'application/config'. Initially, I had all of those folders outside of 'fuel' and in 'projectname' directory. I didn't even had a fuel directory. So then it tried to take me to 'domain/dashboard' whenever I typed in the local domain name. Now that everything is in 'fuel' directory, I just get a 403 forbidden error.

    I'm just trying to set everything up. I'm not exactly sure on how to do that and I'm following the instructions best I can so far.
  • edited 7:01AM
    The normal installation would have a CodeIgniter index.php bootstrap file, an "assets" folder, a "fuel" folder (that contains all those folders you listed above) and a .htaccess file. Normally, you put all that on your web server root or in a sub folder and can access the CMS admin part at /fuel. So for example,

    Normal site is at

    If in a subfolder, you'll need to modify the .htaccess RewriteBase value.
  • edited 7:01AM
    Thanks so much for your intervention. Stupid me. The fuel installation folder already had the files in the correct structure (the structure you mentioned). I have it up and running now.

    The only other question I have is if it's possible to also have a social network api fully integrated with my CodeIgniter installation while I have Fuel cms? Are there any specific social networking api's you recommend that will run parallel with fuel and not interfere with anything?
  • edited 7:01AM
    If you are wanting to integrate with a social API, I'd recommend looking at it from a CodeIgniter perspective. Depending on the social network you are interested in, there's is more then likely a CodeIgniter library that you can include in your fuel/application/library folder that you can use in your controllers.

    We have an advanced module for Campaign Monitor (that can be placed in your fuel/modules/ folder), that may give you an example as to how to code using an API.
  • edited 7:01AM
    Excellent! Thanks so much for the advice and direction. I may have more questions later, but that will come during the creation of the application. Thanks so much.
  • edited 7:01AM
    Okay. Sorry. I ran into one other issue.

    Everything was working fine and I created my first page in the fuel admin panel. Then I noticed that I didn't have mod_rewrite enabled on the apache server. So I enabled it through my Linux terminal and now "" doesn't show (404 not found error). The page I created is still there but I can't get back to the admin panel.
  • edited 7:01AM
    I solved it by adding back $config['index_page']="index.php" and adding a .htaccess file at the root level, but the issue is that I'm trying to git rid of the url http://domain/index.php/about where it puts "index.php" in front of every new page I create.
  • edited 7:01AM
    If you aren't able to get rid of the "index.php", it's usually one of few things:
    1. .htaccess is not properly setup for your web directory (
    2. The mod_rewrite apache module isn't installed (
    3. The RewriteBase value in the .htaccess need to be set to the folder on your webs server that you FUEL installation exists in. By default it is set to the root directory of your web server ("/").
  • edited 7:01AM
    Alright. It took a second to reply. I apologize but I forgot to mention that I have two installations of Fuel CMS: one on WAMP and one on Linux (LAMP). The one on WAMP works fine now. It's the one on Linux that's giving me the issues.

    I followed the instructions you laid out. The only issue is that I "didn't" have the mod_rewrite module installed before I created a local version of the site on LAMP. So I installed the module (sudo a2enmod rewrite), changed the .htaccess commands to the same commands I have in the .htaccess file on WAMP (not sure how I had them different), and I restarted apache2 and I still get the same issue (http://site/fuel/dashboard 404 not found).
  • edited 7:01AM
    Is .htaccess enabled on the LAMP version?
  • edited 7:01AM
    It is enabled. However, I find it weird that the contents of the file were different than the one I had on WAMP. However, it could've been that I copied an htaccess file from another project. What I may do is just rid of the fuel cms files since no site modifications were made and get a fresh installation of fuel files.
  • edited 7:01AM
    OK. Let me know how it goes.
  • edited 7:01AM
    Hello again. So the issue still persist. I decided that I would just use my laptop that has WAMP installed for the fuel cms project. As I mentioned before, it works fine on WAMP. No path issues where I can't rid of "index.php" in the url. The url's are clean.

    So I decided to use Git for version control to push my changes live. Now the live site is on a shared hosting account. I confirmed with the hosting company that mod_rewrite was enabled. The live site is here So after I pushed the local files to the live site, I got 404 errors with and had to edit the config file to include "index.php". So now it's ".../index.php/about".
  • edited 7:01AM
    Is the RewriteBase value in the main .htaccess file /craftandmill/?
  • edited 7:01AM
    Yes it is. I just got off a 42 minute chat with the hosting company going back and forth to make sure that mod_rewrite is enabled and they say it is. They think it's something wrong with the .htaccess file's configuration.

    I use the same configuration file on both setups "shared hosting/live" and "local/WAMP".
  • edited 7:01AM
    I'm guessing yes for this next question but need to ask, is .htaccess enabled for that directory? mod_rewrite may be enabled but if .htaccess for that folder isn't enabled it won't work.
  • edited 7:01AM
    If you are asking about executable permissions for that folder, then yes I have all executable permissions for that directory (read and write as well). If you are saying that outside of enabling mod_rewrite in the parent Apache configuration files, there is an extra step to enable .htaccess I wouldn't know if that extra step has been taken. Also, I would be new to that extra step. Please enlighten me if it is.
  • edited 7:01AM
    Hello admin.

    Just wanted to tell you that it is solved.

    I found that when you are creating a site using Fuel CMS in a subfolder, then you need to specify that subfolder name in the main .htaccess file.

    So this line: RewriteRule .* index.php/$0 [L]

    Should be this line: RewriteRule .* /subfolder/index.php/$0 [L]

    To access ""
Sign In or Register to comment.