Note the upgraded forum! If you are experiencing issues logging in, you may need to reset your password which should send an email. If the email doesn't arrive, be sure to check your spam folder just in case.

Stuck on Installation Possible Issues with .htaccess?

edited February 2011 in Installation
I have am installing from the master download of Fuel CMS. I can get to the Getting Started screen and have made all suggested changes. Updated my RewriteBase to /fuelcms (package was uploaded to mydomain.com/fuelcms). .htaccess resides in this folder. mod_rewrite is enabled and is working.

When I click the link to go to admin I just get a blank page.

I have updated MY_fuel.php so that admin = TRUE and have installed the database.

I have looked through all the threads here including updating the config file with index.php? and also changing .htaccess to reflect that change. No matter what I do, I am always stuck with a blank page.

Comments

  • edited 7:42AM
    Sounds like it should be working under normal circumstances. A few questions for ya:

    1. Are you able to browse to the page at mydomain.com/fuelcms/index.php?/fuel (with the index.php?... or with the index.php sans "?")
    2. Are you able to get a normal CI 2.0 installation to work for you with a controller method?
    3. What kind of stack are you running it on (LAMP, MAMP, XAMPP, WAMP)?
    4. Is the page empty or if you view source is there content there?
  • edited 7:42AM
    1. Hi yes I can get to the page at that URL it's just blank http://www.plumeriawebdesign.com/fuelcms/index.php?/fuel

    2. I have a test installation of CI 2.0 installed at http://www.plumeriawebdesign.com/aes/ it's contains a small tutorial app from the CI website.

    3. Running on LAMP

    4. Page is empty, no source is generated at all.
  • edited 7:42AM
    OK... a few more questions:

    What is your $config['uri_protocol'] value set to in the fuel/application/config/config.php?

    What is your $config['index_page'] value set to in the fuel/application/config/config.php?

    If you feel like getting your hands dirtier, what happens if you set the uri_protocol to "AUTO" (if it isn't already), and put some debug statements in the fuel/codeigniter/core/URI.php class and figure out which uri_protocol value it is actually using in the the _fetch_uri_string() method?
  • edited February 2011
    Hmm...when I set $config['uri_protocol'] to AUTO I get the Getting Started page at the url from bullet 1 above, it was set to QUERY_STRING.

    Here's the other setting $config['index_page'] = "index.php?";

    Edited to add the following:

    I changed the $config['index_page'] = "index.php?"; setting back to $config['index_page'] = "";

    .htaccess looks like this:

    Options +FollowSymLinks

    RewriteEngine On
    RewriteBase /fuelcms


    Order Deny,Allow
    Deny From All


    # Allow asset folders through
    RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

    # Protect application and system files from being viewed
    RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]


    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule .* index.php/$0 [L]

    Options -Indexes

    With those settings I get a blank screen but at this URL http://www.plumeriawebdesign.com/fuelcms/fuel/dashboard
  • edited 7:42AM
    For your CI 2 test page at:
    http://www.plumeriawebdesign.com/aes/

    Can you create a test controller and method on it so I can test additional URI segments work with .htaccess (e.g. http://www.plumeriawebdesign.com/aes/test). This will help me understand if it is a server/CI issue or specific to FUEL itself.
  • edited February 2011
    There is something strange because I have the same problem. I have the latest version of FUELCMS after I configure everything the admin page i get is a blank page.

    I have tried to install it on 2 different server both linux with a clean install.
    On a local install on Windows it works. Is it possible to be a CI naming related problem.
    It is even stranger that on the same server I have an other site build on CI 2.0 that works without problems.
    Update:
    I have installed the same thing on an other linux server and it works. It seams a problem related to Ubuntu ad CI. I have no explanation on why the other CI install that I have works without problems on the ubuntu server.
  • edited February 2011
    http://dev.hype.ro/active/fuel/dashboard
    After setting $config['log_threshold'] = 4; i get this in the error log:

    <?php if ( ! defined('BASEPATH')) exit('No direct script access allowed'); ?>

    DEBUG - 2011-02-12 13:32:28 --> Config Class Initialized
    DEBUG - 2011-02-12 13:32:28 --> Hooks Class Initialized
    DEBUG - 2011-02-12 13:32:28 --> Utf8 Class Initialized
    DEBUG - 2011-02-12 13:32:28 --> UTF-8 Support Enabled
    DEBUG - 2011-02-12 13:32:28 --> URI Class Initialized
    DEBUG - 2011-02-12 13:32:28 --> Router Class Initialized

    The page in browser is still blank
  • edited 7:42AM
    Ok after more investigation I can see that:
    PHP v. 5.2.9 is working ok
    PHP v. 5.2.10 and 5.2.13 are not working resulting in blank page
    PHP v. 5.3.2 is working ok

    Again tested CI lastest version 2.0 and it works on all the above versions so the problem is somehow related to fuelcms.
  • edited 7:42AM
    I've found that depending on the server setup and configuration, I need to test different values for $config['uri_protocol']
  • edited 7:42AM
    I tried all the values without any luck
  • edited 7:42AM
    I really appreciate the research into the issue. I believe I've replicated the issue on a MAMP install due to the information you provided. I'm looking into a fix and will post it as soon as I can.
  • edited 7:42AM
    OK... I believe I found the issue. It had to do with a comment in the fuel/application/config/MY_fuel_modules.php file that had a space before the closing "/" which was causing an unterminated string error that was being supressed by @ (in case anyone was wondering). A fix has been pushed. Thanks again for the report.
  • edited 7:42AM
    Hi I did removed the space and no more blank page but now accessing:
    http://dev.hype.ro/active/fuel/dashboard
    gets me just back to the welcome page. Strange
  • edited 7:42AM
    That seems like it may be more of a uri_protocol issue. What is it currently set to? Check out this post about half way down where it starts with "miles_kailburn" to see if it helps:
    http://www.getfuelcms.com/forums/discussion/comment/75/#Comment_75
  • edited 7:42AM
    Ok yes it was the QUERY_STRING in my case. Thanks for help
  • edited 7:42AM
    I will grab the latest and see if it works. Thanks for the prompt responses!
  • edited 7:42AM
    Yes it's working now! Thank you <3
  • Had Similar issue was able to get it fixed by changing uri protocol in config to the following:

    $config['uri_protocol'] = "REQUEST_URI";

    and .htaccess as follows:

    RewriteRule .* index.php/$0 [L]
    to
    RewriteRule .* index.php?/$0 [L]

    This allowed me to keep clean urls that did not contain the index.php?.
Sign In or Register to comment.