Plugin var can not be found, maybe you forgot to bind it if it's a custom plugin ?

I'm getting this error message after I created an opt-in controller view, created a page in the admin side and imported the content. When I viewed the page before it was imported into the admin panel, it worked fine. Now it gives me the error "Plugin var can not be found, maybe you forgot to bind it if it's a custom plugin ?". Any idea why that is?

Here is the content that was imported
[code]
<!doctype html>
{*[if lt IE 7]> <![endif]*}
{*[if IE 7]> <![endif]*}
{*[if IE 8]> <![endif]*}
{*[if gt IE 8]>{*> {*















Your title


Your article heading

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales urna non odio egestas tempor. Nunc vel vehicula ante. Etiam bibendum iaculis libero, eget molestie nisl pharetra in. In semper consequat est, eu porta velit mollis nec. Curabitur posuere enim eget turpis feugiat tempor. Etiam ullamcorper lorem dapibus velit suscipit ultrices. Proin in est sed erat facilisis pharetra. Pellentesque auctor neque quis nisl lacinia id rutrum lacus venenatis.

A smaller heading

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales urna non odio egestas tempor. Nunc vel vehicula ante. Etiam bibendum iaculis libero, eget molestie nisl pharetra in. In semper consequat est, eu porta velit mollis nec. Curabitur posuere enim eget turpis feugiat tempor. Etiam ullamcorper lorem dapibus velit suscipit ultrices. Proin in est sed erat facilisis pharetra. Pellentesque auctor neque quis nisl lacinia id rutrum lacus venenatis.

A smaller heading

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales urna non odio egestas tempor. Nunc vel vehicula ante. Etiam bibendum iaculis libero, eget molestie nisl pharetra in. In semper consequat est, eu porta velit mollis nec. Curabitur posuere enim eget turpis feugiat tempor. Etiam ullamcorper lorem dapibus velit suscipit ultrices. Proin in est sed erat facilisis pharetra. Pellentesque auctor neque quis nisl lacinia id rutrum lacus venenatis.

About the author

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales urna non odio egestas tempor. Nunc vel vehicula ante. Etiam bibendum iaculis libero, eget molestie nisl pharetra in. In semper consequat est, eu porta velit mollis nec. Curabitur posuere enim eget turpis feugiat tempor.




window.jQuery || document.write('<\/script>')



var _gaq=[['_setAccount','UA-XXXXX-X'],['_trackPageview']]; // Change UA-XXXXX-X to be your site's ID
(function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];g.async=1;
g.src=('https:'==location.protocol?'//ssl':'//www')+'.google-analytics.com/ga.js';
s.parentNode.insertBefore(g,s)}(document,'script'));


{*[if lt IE 7 ]>

window.attachEvent("onload",function(){CFInstall.check({mode:"overlay"})})

[/code]

p.s. how do I put code tags around my snippets in this forum?

Comments

  • edited 8:14AM
    That is a Dwoo parsing error.

    When you import a static page, it tries to translate the PHP code into Dwoo templating syntax. However, if you have a lot of PHP in your template, then it can cause some problems. In your case, it looks like some comments were translated to Dwoo comments and possibly some other stuff. I would recommend either wrapping your areas of the page you don't javascript with a {literal}.... {/literal} templating tags or putting your javascript into separate files to avoid Dwoo parsing errors.

    Lastly, to avoid having to use complicated Dwoo templating syntax instead of raw php, I'd recommend moving any php logic you can into your layouts or a static block file. If it's a block, then you can import it by calling {fuel_block('myblock')}
  • I don't have any php in the static file that I imported and I set the template to none so there shouldn't be any php being used should there?
  • I wrapped {literal}{/literal} tags around the js code and it works now.

    Can you explain the code tag syntax for this forum?
  • Awesome thanks
  • edited April 2012
    We just ran into this problem with some google analytics javascript. The problem was '{var'

    Eg:

    <script> var _gaq=[['_setAccount','UA-XXXXX-X'],['_trackPageview']]; (function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0]; g.src=('https:'==location.protocol?'//ssl':'//www')+'.google-analytics.com/ga.js'; s.parentNode.insertBefore(g,s)}(document,'script')); </script>

    Wrapping in {literal} works as mentioned or just a space between ' { var' gets it done too.

    .... (function(d,t){ var g ....
  • edited 8:14AM
    I just used the above script because the new Analytics tracking script was creating a parse error with my old install of Fuel (not sure why).

    I'm really happy I found this post. :)
Sign In or Register to comment.