HTAccess 500 Error - Hosting FuelCMS using cPanel

edited May 2013 in Bug Reports
Hello, I'm new with FuelCMS & Web Hosting (my 1st time), and I am using cPanel hosted on IIX8-1 PRO server.
For the sake of simplicity, just call the site "mywebsite.com". This website are available in 3 languages, indonesian/english/chinese (/id, /en, /cn shortcut respectively).

My site was built successfully on my localhost PC, so basically I copied the whole finished site from my localhost to the hosting server using ftp and changed the config, i.e. database settings.

However, I experienced some problems:
1. When a user open "mywebsite.com", he will be redirected to "mywebsite.com/en/home". The redirection still worked, however, I got "500 Internal Server Error" message instead of home page being displayed.

"""
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@lintasbuanaexpress.co.id and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
"""


2. I can't access the admin page of FuelCMS admin page by typing "mywebsite.com/admin", as I got the same Internal Server Error message instead.


For your reference, here's the content of my .htaccess file:
~~~~~~~~~~~~~~~~~~~~~~~~ Start ~~~~~~~~~~~~~~~~~~~~~~~~
Options +FollowSymLinks


RewriteEngine On
RewriteBase /mywebsite.com


Order Deny,Allow
Deny From All


# Allow asset folders through
RewriteRule ^(fuel/modules/(.+)?/assets/(.+)) - [L]

# Protect application and system files from being viewed
RewriteRule ^(fuel/install/.+|fuel/crons/.+|fuel/data_backup/.+|fuel/codeigniter/.+|fuel/modules/.+|fuel/application/.+) - [F,L]


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule .* index.php/$0 [L]

# Prevents access to dot files (.git, .htaccess) - security.
RewriteCond %{SCRIPT_FILENAME} -d
RewriteCond %{SCRIPT_FILENAME} -f
RewriteRule "(^|/)\." - [F]


Options -Indexes
~~~~~~~~~~~~~~~~~~~~~~~~ End ~~~~~~~~~~~~~~~~~~~~~~~~


and here's the directory structure of the file in my hosting server
Home
|- .cpanel
|- .htpasswds
|- .trash
|- access-logs
|- etc
|- mail
|- public_ftp
|- public_html
|....|- assets
|....|- cgi-bin
|....|- .htaccess
|....|- index.php
|....|- robots.txt
|....|- fuel
|........|- application
|........|- codeigniter
|........|- data_backup
|........|- and the rest of fuel_cms files
|
|- tmp
|- www


Can you help me point out which part am I not doing it right?

Thanks beforehand.

Comments

  • edited May 2013
    EDIT
    Issue solved after setting "RewriteBase /" and "RewriteRule .* index.php?/$0 [L]" However, new issue arose as when I accessed fuelcms, the loading is very slow. Even after creating a page, I still couldnt load the page list and eventually the page will crash (which also cause the cpanel to be inaccessible for few minutes)!!

    http://i1317.photobucket.com/albums/t621/Koriol_e-Store/error_zpsf95bb3e2.jpg

    EDIT #2:
    After doing further research, I think I experienced the same bug as this one:
    http://www.getfuelcms.com/forums/discussion/55/some-admin-pages-are-stuck-loading/p1
    According to that thread, it was an issue with the host's and apache's mod security. Apache had a bug in its rule that was blocking jquery.cookie.js.

    But still, I havent been able to solve it.

    Note: I'm running FuelCMS Beta 1.0 on Windows 7/ Mozilla Firefox
  • edited 11:44PM
    Problems solved! I ask my web hosting company to turn off the mod_security & suhosin. Hopefully this would help other ppl with the same issue as mine.
Sign In or Register to comment.